tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: Connector Setting Problem in tomcat 6.0.29
Date Fri, 05 Nov 2010 13:07:14 GMT
> From: rujin raj [mailto:rujinraj@gmail.com] 
> Subject: Re: Connector Setting Problem in tomcat 6.0.29

> I tried a lot. I am not able to point out the problem.Herewith 
> i attached my server.xml file..

When posting long XML files, please strip out the comments, so we don't have to wade through
the junk.
 
>     <Executor name="tomcatThreadPool" namePrefix="catalina-exec-"
>      maxThreads="1000" minSpareThreads="150"/>

You finally have an <Executor> configured; that's good.

>     <Connector port="8080" protocol="HTTP/1.1"
>                connectionTimeout="20000"
>                maxThreads="1000"
>                enableLookups="false" disableUploadTimeout="true"
>                redirectPort="8443" />

You failed to specify the executor attribute in the <Connector>, so the <Connector>
will use its own thread pool, not the <Executor>.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus
for use only by the intended recipient. If you received this in error, please contact the
sender and delete the e-mail and its attachments from all computers.



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message