tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <>
Subject Re: RequestDumperFilter improvement
Date Sat, 13 Nov 2010 12:24:36 GMT
On 12/11/2010 20:51, Christopher Schultz wrote:
> All,
> I would like to propose a new feature for the RequestDumperFilter that
> is similar to the AccessLogValve's "condition" setting, except that it
> is logically opposite: it would be nice to allow a Filter ahead of the
> RequestDumperFilter in the chain to flag the request as dump-able
> instead of having to clear-out a flag: presumably, the act of
> conditionally dumping a request is rare and so the semantics seem
> reasonable to work opposite to AccessLogValve's "condition".
> So, I can submit a patch that does this but the question is what to call
> the configuration attribute. I have several options:
> 1. "condition". This may cause confusion as it acts the opposite way
>    to AccessLogValve's "condition".

Don't like the name "condition"

> 2. "ifSet" or even "if"

"isSet" seems clearer than "if"

> 3. Give the user a choice: "ifSet" /and/ "ifUnset" (or both!)

This seems the best option.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message