tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: NullPointerException when Tomcat calls org.apache.catalina.connector.Request.parseParameters
Date Wed, 06 Oct 2010 21:35:28 GMT
2010/10/6 laredotornado <laredotornado@gmail.com>:
>
> Hi,
>
> I'm using Tomcat 6.0.26 with Java 1.6.  I'm getting a strange
> NullPointerException from a Tomcat class.  My code is …
>
>                if (request != null && request.getParameter(FORM_SUBMIT_SITE_NAME
+
> "FormSubmit") != null) {
>
> and the stack trace is below.  I have verified I'm not passing a null to
> "request.getParameter."  Another thread I found suggests this is an encoding
> issue, but all the characters I'm using are UTF-8.  Any ideas how to
> troubleshoot this further?
>
> Thanks, - Dave
>
>
> java.lang.NullPointerException
>        at
> org.apache.catalina.connector.Request.parseParameters(Request.java:2426)
>        at
> org.apache.catalina.connector.Request.getParameter(Request.java:1040)

The line numbers in your stack trace do not match the Tomcat 6.0.26 sources,

http://svn.apache.org/viewvc/tomcat/tc6.0.x/tags/TOMCAT_6_0_26/java/org/apache/catalina/connector/Request.java?view=markup

What is going on?

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message