Hello Pid, I have set the jk log level to debug and i can see following messages in the mod_jk log. It seems request is going to tomcat and apache is giving 500 error messages. kindly let me know how to proceed further. [Thu Sep 09 12:16:49 2010] [1723:1] [debug] ajp_unmarshal_response::jk_ajp_common.c (669): Header[1] [Pragma] = [No-cache] [Thu Sep 09 12:16:49 2010] [1723:1] [debug] ajp_unmarshal_response::jk_ajp_common.c (669): Header[2] [Cache-Control] = [no-store] [Thu Sep 09 12:16:49 2010] [1723:1] [debug] ajp_unmarshal_response::jk_ajp_common.c (669): Header[3] [Last-Modified] = [FRI, JAN 29 2099 23:59:59 GMT] [Thu Sep 09 12:16:49 2010] [1723:1] [debug] ajp_unmarshal_response::jk_ajp_common.c (669): Header[4] [Expires] = [Thu, 01 Jan 1970 00:00:00 GMT] [Thu Sep 09 12:16:49 2010] [1723:1] [debug] ajp_unmarshal_response::jk_ajp_common.c (669): Header[5] [Content-Type] = [text/html] [Thu Sep 09 12:16:49 2010] [1723:1] [debug] ajp_unmarshal_response::jk_ajp_common.c (669): Header[6] [Content-Length] = [855] [Thu Sep 09 12:16:49 2010] [1723:1] [debug] ajp_connection_tcp_get_message::jk_ajp_common.c (1058): received from ajp13 pos=0 len=859 max=8192 [Thu Sep 09 12:16:49 2010] [1723:1] [debug] ajp_connection_tcp_get_message::jk_ajp_common.c (1058): 0000    03 03 57 0D 0A 0D 0A 0D 0A 0D 0A 0D 0A 0D 0A 0D  - ..W............. [Thu Sep 09 12:16:49 2010] [1723:1] [debug] ajp_connection_tcp_get_message::jk_ajp_common.c (1058): 0010    0A 3C 68 74 6D 6C 3E 0D 0A 3C 48 45 41 44 3E 0D  - .... [Thu Sep 09 12:16:49 2010] [1723:1] [debug] ajp_connection_tcp_get_message::jk_ajp_common.c (1058): 0020    0A 0D 0A 0D 0A 0D 0A 0D 0A 20 20 20 20 3C 6C 69  - .............
  • .... [Thu Sep 09 12:16:49 2010] [1723:1] [debug] ajp_connection_tcp_get_message::jk_ajp_common.c (1058): 00a0    0D 0A 0D 0A 0D 0A 0D 0A 09 3C 73 63 72 69 70 74  - .........