tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jan gestre <ipcopper...@gmail.com>
Subject Re: Tomcat dies after starting
Date Thu, 02 Sep 2010 00:32:27 GMT
On Wed, Sep 1, 2010 at 4:40 PM, Wesley Acheson <wesley.acheson@gmail.com> wrote:
> Can you put in the beginning of the stack trace?
>
> Some things to look at make sure that you have permission to bind to
> the port that you've set your http connection to. (you probably won't
> be able to bind to port 80 on a linux box)
>
> RHEL5 has selinux installed by default which may cause problems. I'm not sure.
> Ensure nothing else is listening to that port.
>
> Regards,
>
> Wesley Acheson
>
> On Wed, Sep 1, 2010 at 9:00 AM, jan gestre <ipcopper.ph@gmail.com> wrote:
>> Hi Everyone,
>>
>> I'm using 6.0.26 tomcat binary in my RHEL5 box, it was configured for
>> high availability using DRBD, it was already working for more than a
>> week already but all of a sudden it stopped working, tomcat just dies,
>> restarting it manually does not help either.
>>
>> Here's my setup:
>>
>> RHEL5 64bit
>> Sun Java 1.6 SDK 64 bit
>> Tomcat 6.0.29
>>
>> Here's my catalina.out log which is the same as the catalina.2010-09-01.log:
>>
>> logs/catalina.out
>>        at
>> org.apache.catalina.connector.MapperListener.destroy(MapperListener.java:176)
>>        at org.apache.catalina.connector.Connector.stop(Connector.java:1135)
>>        at
>> org.apache.catalina.core.StandardService.stop(StandardService.java:596)
>>        at
>> org.apache.catalina.core.StandardServer.stop(StandardServer.java:744)
>>        at org.apache.catalina.startup.Catalina.stop(Catalina.java:648)
>>        at
>> org.apache.catalina.startup.Catalina$CatalinaShutdownHook.run(Catalina.java:692)
>> Sep 1, 2010 1:44:26 PM org.apache.coyote.http11.Http11Protocol destroy
>> INFO: Stopping Coyote HTTP/1.1 on http-8080
>> Sep 1, 2010 1:44:26 PM org.apache.catalina.connector.Connector stop
>> SEVERE: Coyote connector has not been started
>> ---
>>
>> Here's the log when it was working/running:
>>
>> catalina.2010-08-23.log
>> Aug 23, 2010 3:00:16 PM org.apache.coyote.http11.Http11Protocol start
>> INFO: Starting Coyote HTTP/1.1 on http-8080
>> Aug 23, 2010 3:00:16 PM org.apache.jk.common.ChannelSocket init
>> INFO: JK: ajp13 listening on /0.0.0.0:8009
>> Aug 23, 2010 3:00:16 PM org.apache.jk.server.JkMain start
>> INFO: Jk running ID=0 time=0/16  config=null
>> Aug 23, 2010 3:00:16 PM org.apache.catalina.startup.Catalina start
>> INFO: Server startup in 513 ms
>> Aug 23, 2010 3:10:19 PM org.apache.coyote.http11.Http11Protocol pause
>> INFO: Pausing Coyote HTTP/1.1 on http-8080
>>
>> I've already googled similar issues but did not find any concrete solution.
>>
>> Will appreciate any help.
>>
>> Many thanks in advance.
>>
>> Jan
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

Hi Wesley,

SELinux is disabled as well as the firewall, and Tomcat is running as
unprivileged user, all related files is owned by that user.

Jan

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message