tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Gardiner <gardin...@gmail.com>
Subject Tomcat 5.5.30 - connection refused with APR
Date Tue, 28 Sep 2010 17:27:55 GMT
Hello,

I've set up Tomcat 5.5.30 and am using the native interface but the ports
don't seem be be opening.

I'm using APR version 1.4.2  (built with disable ipv6)
OpenSSL 0.9.7m
Tomcat Native Interface 1.1.20 (supplied in tomcat 5.5.30 archive)

I have two connectors defined, one on port 8080 and one on port 8443

My tomcat log contains the following output:

[2010-09-28 13:00:48,512] INFO main
org.apache.catalina.core.AprLifecycleListener - Loaded APR based Apache
Tomcat Native library 1.1.20.
[2010-09-28 13:00:48,514] INFO main
org.apache.catalina.core.AprLifecycleListener - APR capabilities: IPv6
[false], sendfile [true], accept filters [false], random [true].
[2010-09-28 13:00:49,053] INFO main
org.apache.coyote.http11.Http11AprProtocol - Initializing Coyote HTTP/1.1 on
http-8080
[2010-09-28 13:00:49,057] INFO main
org.apache.coyote.http11.Http11AprProtocol - Initializing Coyote HTTP/1.1 on
http-8443
[2010-09-28 13:00:49,059] INFO main org.apache.coyote.ajp.AjpAprProtocol -
Initializing Coyote AJP/1.3 on ajp-8009
[2010-09-28 13:00:49,059] INFO main org.apache.catalina.startup.Catalina -
Initialization processed in 1892 ms


So it looks as if APR is loaded and ports 8080/8443 are opened.

When I run netstat I see
tcp 0 0 0.0.0.0:8080 0.0.0.0:* LISTEN 9668/java
tcp 0 0 0.0.0.0:8443 0.0.0.0:* LISTEN 9668/java

So the ports have been opened, and I've completely disabled the firewall but
I still get connection refused messages.

Any ideas on where to look next for the cause of the trouble?

I'm running RedHat with  kernel 2.4.18

Thanks,
Mike

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message