tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: Slow "network" with additional Connector (Port) in tomcat
Date Thu, 02 Sep 2010 15:38:55 GMT
> From: Yoav Naveh [mailto:yoavnaveh@gmail.com] 
> Subject: Re: Slow "network" with additional Connector (Port) in tomcat

> Some more information:
> Tomcat is using OpenJdk6, on Ubuntu 8.04

You still haven't told us the Tomcat version you're using.

> I have attached my server.xml file.

There are no <Connector> elements for the specified redirect port, but that shouldn't
affect this testing.

You should not be putting <Context> elements in server.xml; doing so will likely result
in double deployment of webapps and confusion in where requests are routed.  You should remove
both <Context> elements, rename your myDoc to ROOT (case sensitive), and place just
the following in webapps/ROOT/META-INF/context.xml:

<Context allowLinking="true" />

If you need to access the webapp with the http://<server>/myDoc URL, either create a
dummy myDoc webapp that redirects to ROOT, or use a filter in webapps/ROOT/WEB-INF/web.xml
to redirect.

Clean up those obvious problems, then retest.  It likely won't make a difference, but it will
eliminate variables that shouldn't be there.  Also, try enabling the AccessLogValve to see
Tomcat's view of request/response timing.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus
for use only by the intended recipient. If you received this in error, please contact the
sender and delete the e-mail and its attachments from all computers.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message