tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: warning: Setting property 'source' [...] did not find a matching property.
Date Thu, 30 Sep 2010 15:44:24 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

August,

On 9/30/2010 11:05 AM, Dwight, August wrote:
> WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context}
> Setting property 'source' to 'org.eclipse.jst.j2ee.server:myappname'
> did not find a matching property.

You're trying to set the "source" attribute on your <Context> element.

A few suggestions:

1. Don't set the "source" attribute on your <Connector> (there is no
   such configuration property)
2. Don't put your <Context> in your server.xml. Instead, put it into
   your webapp's META-INF/context.xml file. Don't have one? Create one.

> When this warning is present, my server starts successfully with no
> errors

Not a surprise: that's a warning.

> but the application does not appear to start and is not
> accessible.

That's strange.

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkyksFgACgkQ9CaO5/Lv0PA+MQCcDil83eLMErpIx9prOqohfVoK
ZBEAnjWfPh/wRkPM1pVdzjz67cDWnI3D
=QKuV
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message