tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Tomcat 6.0 and Windows 7
Date Mon, 27 Sep 2010 20:16:35 GMT
Wesley Acheson wrote:
> Hi is that all thats in the log. It appears read timeout should be
> caused by an upstream IO Exception.

That is obviously what the server is saying.
It seems that the server is trying to read what the browser should be sending, but that 
the browser closes the connection before everything is sent. So the server tries to read 
from a closed connection, and that triggers an exception.

The question is : why is the server only saying that for the Windows-7 station, and with 2

different browsers ?


Apart from possibly the bug which Ongjen mentioned, I would recommend to Julie the following
:

1) On both the Windows XP and the Windows-7 machine, install the HttpFox plugin/extension

into the Firefox browser (find it on the www).
(This is a very useful plugin, which can show you everything that goes from the 
workstation 's Firefox to the server, and vice-versa.
It is an essential tool to diagnose this kind of issue.)

Then activate the plugin ("in a separate window") on both workstations, and do the upload

again.
Then compare what you see in the HttpFox windows.

2) get another, 3rd PC, preferably also Windows-7, to do the same test.  This is just to 
find out if the issue is particular to that one specific Windows-7 PC, or to Windows-7 PCs

in general.


> 
> Wes
> 
> On Mon, Sep 27, 2010 at 2:51 PM, Julie Gautier <j.gautier@actes-sud.fr> wrote:
>> Hello,
>>
>> I wrote a web application, that works great with a server under Tomcat
>> 6.0.13 and client with Windows XP OS, in which user has to upload (text)
>> files that are read and exploited.
>>
>> I tried this application (on a client machine) under Windows 7 and it works
>> with uploaded files around 5-6 kb but if I try to upload a file around 60
>> kb, it doesn't work anymore and the "localhost. .log" trace file indicates
>> the following error :
>>
>>
>>
>> org.apache.commons.fileupload.FileUploadException: Processing of
>> multipart/form-data request failed. Read timed out
>>
>>                at
>> org.apache.commons.fileupload.FileUploadBase.parseRequest(FileUploadBase.jav
>> a:384)
>>
>>                at
>> org.apache.commons.fileupload.FileUploadBase.parseRequest(FileUploadBase.jav
>> a:268)
>>
>>                at
>> org.apache.struts.upload.CommonsMultipartRequestHandler.handleRequest(Common
>> sMultipartRequestHandler.java:193)
>>
>>                at
>> org.apache.struts.util.RequestUtils.populate(RequestUtils.java:443)
>>
>>                at
>> org.apache.struts.action.RequestProcessor.processPopulate(RequestProcessor.j
>> ava:796)
>>
>>                at
>> org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:203)
>>
>>                at
>> org.apache.struts.action.ActionServlet.process(ActionServlet.java:1192)
>>
>>                at
>> org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:430)
>>
>>                at
>> javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
>>
>>                at
>> javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
>>
>>                at
>> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Application
>> FilterChain.java:290)
>>
>>                at
>> org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterCh
>> ain.java:206)
>>
>>                at
>> org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.ja
>> va:230)
>>
>>                at
>> org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.ja
>> va:175)
>>
>>                at
>> org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128
>> )
>>
>>                at
>> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104
>> )
>>
>>                at
>> org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java
>> :109)
>>
>>                at
>> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:261)
>>
>>                at
>> org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
>>
>>                at
>> org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http
>> 11Protocol.java:581)
>>
>>                at
>> org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
>>
>>                at java.lang.Thread.run(Unknown Source)
>>
>>
>>
>> Could you please help me to make my application work with client under
>> Windows 7 ?
>>
>> Thanks in advance.
>>
>>
>>
>> Julie Gautier
>>
>>
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message