tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pid <...@pidster.com>
Subject Re: Problems with SSI
Date Thu, 09 Sep 2010 14:40:15 GMT
On 09/09/2010 14:57, jeffo1b wrote:
> 
> I've tried following all of the advice in the previous threads, but I'm up
> against a wall here.
> 
> I have added <Context privileged="true> to my context.xml 
> In the same directory, i have uncommented the SSI Filter as well as the
> Filter mapping and the *.shtml mime mapping in web.xml.  see below:
> 
> <filter>
>         <filter-name>ssi</filter-name>
>         <filter-class>
>           org.apache.catalina.ssi.SSIFilter
>         </filter-class>
>         <init-param>
>           <param-name>contentType</param-name>
>           <param-value>text/x-server-parsed-html(;.*)?</param-value>
>         </init-param>
>         <init-param>
>           <param-name>debug</param-name>
>           <param-value>0</param-value>
>         </init-param>
>         <init-param>
>           <param-name>expires</param-name>
>           <param-value>666</param-value>
>         </init-param>
>         <init-param>
>           <param-name>isVirtualWebappRelative</param-name>
>           <param-value>0</param-value>
>         </init-param>
>     </filter>
>    
>     <filter-mapping>
>         <filter-name>ssi</filter-name>
>         <url-pattern>*.shtml</url-pattern>
>     </filter-mapping>
> <mime-mapping>
>         <extension>shtml</extension>
>         <mime-type>text/x-server-parsed-html</mime-type>
>     </mime-mapping>
> 
> Finally, i have a file called test.shtml that has the following code:
> <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
> "http://www.w3.org/TR/html4/loose.dtd">
> <html>
> <head>
> <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
> <title>tester</title>
> </head>
> <body>
> hi there
> <!-- #include file="/inc.html" -->
> </body>
> 
> The "inc.html" file is in the same directory as the test.html file.  when I
> run the file, i simply see the "hi there" and none of the contents of the
> inc.html file.  
> 
> 1.  i don't have the invoker servlet un-commented.  is this required?
> 2.  i got totally lost on the reg -exp discussions.  i am not in the IT
> world and it was simply beyond my skill set.
> 
> Anybody have an idea where I've gone wrong?
> 
> Much appreciated.
> 
> jeff
> 

Unless my email client is broken, you've sent the same message 4 times.
André replied to an earlier message, you should read his response.


p


Mime
View raw message