tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amol Puglia <amolcpug...@yahoo.com>
Subject Re: Tomcat Load Balancing Not working and Apache URL is giving 500 error
Date Thu, 09 Sep 2010 07:55:33 GMT
Hello Andrew,

Thanks for the response.

I have tried the alternatives provided by you,but it didnt worked for me.

Yes, I have enabled ssl at apache level.

#Load Balance worker configuration

worker.loadbalancer.type=lb

worker.loadbalancer.balanced_workers=tomcat1,tomcat2

worker.loadbalancer.balanced_workers=tomcat1,tomcat3

worker.loadbalancer.balanced_workers=tomcat2,tomcat3




--- On Thu, 9/9/10, Andrew Bruno <andrew.bruno@gmail.com> wrote:

From: Andrew Bruno <andrew.bruno@gmail.com>
Subject: Re: Tomcat Load Balancing Not working and Apache URL is giving 500 error
To: "Tomcat Users List" <users@tomcat.apache.org>
Date: Thursday, September 9, 2010, 1:13 PM

Hi Amol,

I am trying to do the exact same thing.  It works for two workers, but
fails as soon as I add one worker.

Can you please try these alternatives, and let me know if it works for you?

worker.loadbalancer.balanced_workers=tomcat1,tomcat2

worker.loadbalancer.balanced_workers=tomcat1,tomcat3

worker.loadbalancer.balanced_workers=tomcat2,tomcat3

For me, as long as I have two workers, it works.  It would be
interesting if its the same for you?

I also came across these links which I am reviewing.  It may help you.

http://thought-bytes.blogspot.com/2007/03/how-to-load-balance-tomcat-55-with.html
http://www.quadbase.com/eres/manual/6_4_Clustering.html
http://www.zulutown.com/blog/2009/02/16/java-ee-load-balancing-with-tomcat-and-apache/

Last question, do you have SSL enabled?

AB


On Thu, Sep 9, 2010 at 5:28 PM, Amol Puglia <amolcpuglia@yahoo.com> wrote:
> Hello Team,
>
> We have installed one instance of apache and 3 instance of tomcat.
>
> We have compiled mod_jk module to forward request to 3 instance of tomcat.
>
> We have configured workers.properties and it is loaded in httpd.conf file.
>
> We are successfully able to redirect request to plain tomcat installation.
>
> We are getting 500 internal server error while accessing apache url after deploying our
EMATRIX application.
>
> Below are the details of workers.properties file and httpd.conf file.
>
> # lists the workers by name
>
> worker.list=loadbalancer
>
> # Tomcat1 configuration
>
> worker.tomcat1.port=8009
>
> worker.tomcat1.host=server_name
>
> worker.tomcat1.type=ajp13
>
> worker.tomcat1.lbfactor=100
>
> # Tomcat2 configuration
>
> worker.tomcat2.port=8010
>
> worker.tomcat2.host=server_name
>
> worker.tomcat2.type=ajp13
>
> worker.tomcat2.lbfactor=100
>
> # Tomcat3 configuration
>
> worker.tomcat3.port=8011
>
> worker.tomcat3.host=server_name
>
> worker.tomcat3.type=ajp13
>
> worker.tomcat3.lbfactor=100
>
>
> #Load Balance worker configuration
>
> worker.loadbalancer.type=lb
>
> worker.loadbalancer.balanced_workers=tomcat1,tomcat2,tomcat3
>
>
> Httpd.conf file details :-
>
> LoadModule jk_module modules/mod_jk.so
>
> JkWorkersFile conf/workers.properties
>
> JkLogFile logs/mod_jk.log
>
> JkLogLevel info
>
> JkMount /eMatrix/* loadbalancer
>
>
> Apache Version details :- 2.0.59
>
> Tomcat Version details :- apache-tomcat-6.0.20
>
> Mod_jk version details :- mod_jk-1.2.24
>
> We have also noticed that jk module is loading properly in apache.
>
> [Tue Sep 07 09:43:29 2010] [notice] Apache/2.0.59 (Unix) mod_jk/1.2.24 DAV/2 mod_ssl/2.0.59
OpenSSL/0.9.7d configured -- resuming normal operations
>
>
> kindly help me to acheive loadbalancing from apache to tomcat.
>
>
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org




      
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message