tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carlton Whitmore" <cwhitm...@Advocacyinc.org>
Subject RE: Single Sign-On problems
Date Mon, 16 Aug 2010 01:48:02 GMT
Andre,
The only reason I think it's Tomcat because when we change the Tomcat version it seems to
affect the speed of the application (Tomcat 7 runs very slow, but no SSO errors; Tomcat 6
runs fast, but SSO errors). We're using Active Directory to authenticate. I guess it could
be SSL as well. I've change the domain controller, but that didn't affect the issue. Here
is the code we changed in the conf\web.xml file:
 
 <welcome-file-list>
        <welcome-file>index.html</welcome-file>
        <welcome-file>index.htm</welcome-file>
        <welcome-file>index.jsp</welcome-file>
    </welcome-file-list>
 
   <filter>
     <filter-name>NtlmHttpFilter</filter-name>
     <filter-class>jcifs.http.NtlmHttpFilter</filter-class>
     <init-param>
         <param-name>jcifs.http.domainController</param-name>
         <param-value>192.168.100.6</param-value>
     </init-param>
     <init-param>
         <param-name>jcifs.smb.client.domain</param-name>
         <param-value>advocacyinc</param-value>
     </init-param>
     <init-param>
         <param-name>jcifs.smb.client.username</param-name>
         <param-value>SQL_LegalFiles</param-value>
     </init-param>
     <init-param>
         <param-name>jcifs.smb.client.password</param-name>
         <param-value>>password</param-value>
     </init-param>
     <init-param>
         <param-name>jcifs.smb.lmCompatibility</param-name>
         <param-value>3</param-value>
     </init-param>
    <!-- ** needs reviewed to avoid domain Preauth check
    init-param>
        <param-name>jcifs.smb.client.ssnLimit</param-name>
        <param-value>1</param-value>
    </init-param>
    -->
</filter>
<filter-mapping>
    <filter-name>NtlmHttpFilter</filter-name>
    <url-pattern>/*</url-pattern>
</filter-mapping>

 
Carlton Whitmore
Systems Analyst
Advocacy, Inc.
http://www.advocacyinc.org <https://exchange2003.advocacyinc.org/exchweb/bin/redir.asp?URL=http://www.advocacyinc.org/>

 

________________________________

From: André Warnier [mailto:aw@ice-sa.com]
Sent: Sun 8/15/2010 11:45 AM
To: Tomcat Users List
Subject: Re: Single Sign-On problems



Carlton Whitmore wrote:
> We're running Windows 2008 R2, Tomcat 6, MS SQL 2005, JDK 6 update 20
> and authenticating using AD from Windows 2003 R2 server.
>
> 
>
> The application we're using causes intermittent single sign-on errrors.
> We tried to upgrade to Tomcat 7 and the SSO errors went away, but the
> system was so slow it was unusable. Sometimes we get 8 SSO errors before
> we're able to use the system, but when it works it's very fast.
>
Would you mind specifying which SSO mechanism you are using where, and why you believe
that the problem is related to Tomcat ?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org





---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message