tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zeigler, Carl L" <clzeig...@statestreet.com>
Subject Can't configure webapps to disk partition
Date Wed, 11 Aug 2010 15:17:16 GMT

Hello and thank you in advance for any suggestions you may have.

I am running Tomcat 6.0.24 (service) on a Windows 2003 server hosting
very simple JSP pages.

I am trying to make a configuration change to server.xml to change the
webapps directory to a different disk partition as below but I cannot
get it to work
From:
<Host name="localhost" appBase="webapps" unpackWARs="true"
autoDeploy="true" xmlValidation="false" xmlNamespaceAware="false">

To:
<Host name="localhost" appBase="E:\prod\applications" unpackWARs="true"
autoDeploy="true" xmlValidation="false" xmlNamespaceAware="false">


I have had success changing the webapps directory to various locations
on the C: Drive but when I try to use the E: partition, I receive the
"page cannot be found" message. 

The reason I need to do this is because the path (E:\prod\applications)
is the target source code deployment path required by my employer. 

I have found several posts in the forum that suggest variations on the
syntax as noted below but still, I have not been able to get anything to
work.

The WEB-INF and META-INF as well as web.xml are all present in the
E:\prod\applications\<project name> folder and I have restarted the
Tomcat service after my changes. 

I have tried many variations of these:
E://prod//applications
\E:\prod\applications


Thank you,
Carl



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message