tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From abhishek jain <abhishek.netj...@gmail.com>
Subject Re: Expression language not working
Date Tue, 31 Aug 2010 15:38:24 GMT
Hey ,
I just realized that actually i accidently placed el-api.jar in WEB-INF/lib
folder.
If i dont than i get the following exception:


Aug 31, 2010 4:28:44 PM org.apache.catalina.core.
StandardContext listenerStart
SEVERE: Error configuring application listener of class
com.sun.faces.config.ConfigureListener
java.lang.NoClassDefFoundError: javax/el/ExpressionFactory
        at java.lang.Class.getDeclaredConstructors0(Native Method)
        at java.lang.Class.privateGetDeclaredConstructors(Class.java:2389)
        at java.lang.Class.getConstructor0(Class.java:2699)
        at java.lang.Class.newInstance0(Class.java:326)
        at java.lang.Class.newInstance(Class.java:308)
        at
org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3744)
        at
org.apache.catalina.core.StandardContext.start(StandardContext.java:4252)
        at
org.apache.catalina.manager.ManagerServlet.start(ManagerServlet.java:1173)
        at
org.apache.catalina.manager.HTMLManagerServlet.start(HTMLManagerServlet.java:549)
        at
org.apache.catalina.manager.HTMLManagerServlet.doGet(HTMLManagerServlet.java:105)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:627)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
        at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
        at
org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:525)
        at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
        at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
        at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:174)
        at
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:873)
        at
org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665)
        at
org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528)
        at
org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81)
        at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:689)
        at java.lang.Thread.run(Thread.java:619)
Caused by: java.lang.ClassNotFoundException: javax.el.ExpressionFactory
        at
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1386)
        at
org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1232)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:316)
        ... 27 more



and the application is not started.

thanks
abhishek
On Tue, Aug 31, 2010 at 8:42 PM, abhishek jain
<abhishek.netjain@gmail.com>wrote:

> hey
> I was looking at the tomcat commons lib folder, there is a file called
> commons-el.jar
>
> has that something to do with el-api.jar in my WEB-INF/lib folder ?
>
>
> thanks
> abhishek
>
>
> On Tue, Aug 31, 2010 at 6:26 PM, abhishek jain <abhishek.netjain@gmail.com
> > wrote:
>
>> yes, it was originally 2.5, i did tried changing it to 2.4 and of no use,
>>
>>
>> thanks for answering but the problem still persists.
>>
>> abhishek
>>
>>
>> On Tue, Aug 31, 2010 at 6:16 PM, Ben Souther <ben@souther.us> wrote:
>>
>>> Look at the top of your deployment descriptor (web.xml) and see if the
>>> version is 2.4 or better.
>>>
>>>
>>>
>>>
>>>
>>> On Aug 31, 2010, at 8:35 AM, abhishek jain wrote:
>>>
>>> > On Tue, Aug 31, 2010 at 5:48 PM, Mark Thomas <markt@apache.org> wrote:
>>> >
>>> >> On 31/08/2010 12:52, abhishek jain wrote:
>>> >>> Hi friends,
>>> >>> I have a website in struts 1.2 hosted on tomcat 5.5.x and it uses
EL.
>>> >>> It is not being evaluated, any suggestions on the reasons why?
>>> >>
>>> >> http://www.catb.org/esr/faqs/smart-questions.html
>>> >>
>>> >> ---------------------------------------------------------------------
>>> >> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>>> >> For additional commands, e-mail: users-help@tomcat.apache.org
>>> >>
>>> >>
>>> >
>>> > Hey Mark,
>>> > Sorry but
>>> > What info should i provide for people to help me here, i am clueless.
>>> > I used struts 1.2 , myeclipse, tomcat 5.5.28 .
>>> > EL is not working on live but works on development environment on
>>> myeclipse.
>>> > --
>>> > Thanks and kind Regards,
>>> > Abhishek jain
>>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message