tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean McEligot <seanmc...@gmail.com>
Subject Re: war not redeploying
Date Wed, 18 Aug 2010 15:37:35 GMT
On Wed, Aug 18, 2010 at 11:30 AM, Pid <pid@pidster.com> wrote:
> On 18/08/2010 15:57, Sean McEligot wrote:
>> My goal is that when I put an updated war file in webapps, it is
>> deployed either immediately or on the next startup. I prefer startup,
>> but I'd  be happy with either. What happens now is sometimes even
>> after restarting the expanded war is older than the war in webapps.
>> Nothing seems to get tomcat to notice the new war except: shutdown; rm
>> -rf webapps/appname work/* temp/*; startup.
>>
>> My platorm is Windows, but this will be deployed in Solaris. I don't
>> know if this is a configuration problem or something in my code could
>> be preventing redeployment. At least knowing where to look would be
>> helpful.
>>
>> Here's my current configuration, though I've tried many variations
>> including context xml fragements and unexpanded wars.
>>
>> --- server.xml
>>       <Host name="localhost"  appBase="webapps"
>>             unpackWARs="true" autoDeploy="true" deployOnStartup="true"
>> deployXML="true"
>>             xmlValidation="false" xmlNamespaceAware="false">
>>       </Host>
>> ---
>> ---- context.xml
>> <Context debug="1" privileged="false" unpackWAR="true"
>> antiJARLocking="true" antiResourceLocking="true" unloadDelay="180000">
>>
>>     <!-- Default set of monitored resources -->
>>     <WatchedResource>build.txt</WatchedResource>
>> ----
>> build.txt is in the root of the war. it is updated each build using
>> ant's buildnumber task.
>
> Exact Tomcat version?

6.0.25

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message