tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: OFFTOPIC: Java String problem - possible VM bug
Date Tue, 31 Aug 2010 00:02:56 GMT
> From: Steffen Heil [mailto:lists@steffen-heil.de] 
> Subject: AW: OFFTOPIC: Java String problem - possible VM bug

> java version "1.6.0_21"
> Java(TM) SE Runtime Environment (build 1.6.0_21-b06)
> Java HotSpot(TM) 64-Bit Server VM (build 17.0-b16, mixed mode)

> So I should update, right?

It's worth trying.

> The linux box has intel core i7 920 (xen domU), the windows host 
> has intel core2duo t5670.

I think that means the Windows box does not have SSE4 (or at least not 4.2), which has been
the recent problem with String handling.

> 2) I thougth 64bit vms would not have a client mode....

You're right, it doesn't, at least on Windows.

There is a -XX option to limit or disable SSE usage:

-XX:UseSSE=n

where n is the highest SSE version to use.  Might try setting it to 3 or less and see if anything
changes.

There's also -XX:-UseSSE42Intrinsics, but that should be off by default already.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus
for use only by the intended recipient. If you received this in error, please contact the
sender and delete the e-mail and its attachments from all computers.



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message