tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From DANA HEATH <djhe...@pacbell.net>
Subject Proxy Configuration + SSL
Date Fri, 13 Aug 2010 19:58:27 GMT
Hi all,
 
I'm running into an SSL configuration problem running several web servers behind 
a proxy. I have a wildcard cert for my domain (call it m.com) on the proxy 
server, but need to secure a credit card form on each webserver running as a 
sub-domain behind the proxy. Here are my configs (running Tomcat 6.0.29 on 
64-bit CentOS):
 
web-server's web.xml security snippet:
    <security-constraint>
        <web-resource-collection>
            <web-resource-name>Protected resource</web-resource-name>
            <url-pattern>/cc.jsp</url-pattern>
            <http-method>GET</http-method>
            <http-method>POST</http-method>
        </web-resource-collection>
        <user-data-constraint>
            <transport-guarantee>CONFIDENTIAL</transport-guarantee>
        </user-data-constraint>
    </security-constraint>

web-server's server.xml connector snippet:
    <Connector port="8080" protocol="HTTP/1.1"
               connectionTimeout="20000" proxyName="web01.m.com" proxyPort="80"
               redirectPort="443" />

The proxy is running on ports 80 / 443. There is no SSL cert on the individual 
web servers.
 
When the browser client gets directed to cc.jsp, the web server gets caught in 
an infinite loop. Has anyone dealt with this type of configuration and if so, 
what am I doing wrong? Thanks in advance,
 
-Dana     
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message