tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: UTF-8 encoding in Tomcat 6.0
Date Tue, 03 Aug 2010 16:00:01 GMT
On 03/08/2010 16:52, arun kumar wrote:
> Thanks.
> If i copy the test.jsp to the sampleweb folder and change the FORM method to GET instead
of post, when i submit, i get this in the addressbar:
> 
> http://localhost:8080/sampleweb/test.jsp?mydata=%25d8
> 
> and %xx is displayed correctly.
> 
> If i give 
> http://localhost:8080/sampleweb/test.jsp?mydata=%d8
>  
> again ? is displayed

Do this on a completely clean Tomcat 6.0.29 install that has not been
modified apart from to set the URIEncoding attribute on the connector.

Mark

> 
> Thanks and regards
> Arun
> 
> --- On Tue, 8/3/10, Mark Thomas <markt@apache.org> wrote:
> 
>> From: Mark Thomas <markt@apache.org>
>> Subject: Re: UTF-8 encoding in Tomcat 6.0
>> To: "Tomcat Users List" <users@tomcat.apache.org>
>> Date: Tuesday, August 3, 2010, 7:25 AM
>> On 03/08/2010 12:18, arun kumar
>> wrote:
>>> Am i sending some parameter wrongly?
>>
>> Probably.
>>
>> Go back and read what I wrote about the test JSP on the
>> wiki and see if
>> that works.
>>
>> Mark
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>
> 
> 
>       
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message