tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Caine <step...@commongrnd.com>
Subject Re: Session problem
Date Wed, 25 Aug 2010 13:50:15 GMT
Jason,

I was referring to an issue where a user opens several tabbed references to the same window.
 If the session value is changed in one window, the value will change in subsequent references
in the other tabbed window(s).  Actually, this is significant problem, but if this is not
what was being asked, then ignore my comment.

Stephen

On Aug 24, 2010, at 8:06 PM, Jason Britton wrote:

> Stephen - your statement doesn't really make sense in context to the
> problem he described or how I replied.  From Hisham's first post I
> believe he's describing tabs within the context of a single web page
> interface, when he clicks on any of the three tabs a request is made
> (asynchronous or otherwise), request passes through a servlet filter
> that checks for existence of session attribute etc..  I was suggesting
> he check that he hadn't, for some unknown reason, hardcoded a
> different domain for the "Messages" link, if that were the case that
> domain (eg. localhost instead of dev2) would not have the same session
> as the other links and the session attribute value he was looking for
> might not be there, which would fit with what he's describing.
> 
> Jason
> 
> 
> On Tue, Aug 24, 2010 at 3:37 PM, Stephen Caine <stephen@commongrnd.com> wrote:
>> Jason,
>> 
>> As each window shares the same session, a change to the session value in one window
will effect the session value in the others.
>> 
>> Stephen Caine
>> 
>> On Aug 24, 2010, at 5:21 PM, Jason Britton wrote:
>> 
>>> I would make sure that the link for your "Messages" tab is going to the same
>>> domain as that your session was established under and is hitting the same
>>> domain as your "Home" and "Admin" links.  This doesn't seem to have anything
>>> to do with Tomcat though.
>>> 
>>> 
>>> On Tue, Aug 24, 2010 at 1:53 PM, Hisham <mohisham@gmail.com> wrote:
>>> 
>>>> Hello all,
>>>> 
>>>> I have a problem that is driving me crazy.  I don't even know if its a
>>>> Tomcat issue but maybe someone out there can help me out.
>>>> 
>>>> I have a webapp that I first developed locally.  I tested this on my
>>>> local environment (windows) and had no issues.  I then deployed the
>>>> same app to our QA environment (linux).  There i am seeing something
>>>> strange.  There are three main tabs, "Home", "Messages" and "Admin".
>>>> I can go between home and admin, no probs.  But once i click on
>>>> Messages, somehow the session on the server gets messed up.  The way i
>>>> check whether session is valid is not is that I have a filter that
>>>> will check if a certain attribute is present in the session or not.
>>>> If its not, i assume the session is invalid and forward to login page.
>>>> As soon as i click on the Messages link, i cannot do anything else;
>>>> anywhere else i click it takes me to the login page.  I put print
>>>> statements in my filter and verified that it is not able to find the
>>>> attribute in the session.  Which is strange because the session id is
>>>> the same (i have verified by printing it out, and also seeing what is
>>>> sent in the actual request headers via firebug).  I am not removing
>>>> the attribute from the session in any place; and in any case it works
>>>> fine locally as i said before.
>>>> 
>>>> Does any one have any clue as to what could be happening?  I can post
>>>> code if needed, but i don't know where to begin :)
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message