tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Goodenough <david.goodeno...@btconnect.com>
Subject Re: trouble with url-pattern in a filter-mapping (tomcat 6)
Date Fri, 20 Aug 2010 15:27:03 GMT
On Friday 20 August 2010, Pid wrote:
> On 20/08/2010 10:40, David Goodenough wrote:
> > I am trying to configure a filter to handle just requests to a single
> > page which for the simplicity I will call page.htm (at the root of my
> > application).
> > 
> > So I created a url-pattern which read:-
> > 
> > <url-pattern>page.htm</url-pattern>
> > 
> > and put it inside my <filter-mapping> tag.
> > 
> > But when I start tomcat6 it throws an exception complaining that this
> > url-pattern is invalid.
> > 
> > I tried with a leading /, I tried *ge.htm in case it wanted a wildcard in
> > there somwhere, but none of them work.
> > 
> > This is in a <webapp version="2.4" if that makes a difference.
> 
> Tomcat6.0.x?
> 
> The url-pattern must start with a '/' character.
> 
> Please post the complete application web.xml.
> 
> 
> p
Actually from reading the source the pattern MUST contain a wildcard.
Simple explicit matches do not work, at least not on 6.0.28.  

David
> 
> > David
> > 
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> > For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message