tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rahul <iamrahu...@yahoo.com>
Subject Re: Tomcat 6.0.26 with Java 6 update 20 on Sun Solaris 5.8 Sparc - Web application unable to execute properly
Date Thu, 01 Jul 2010 23:25:12 GMT
This email contained a .zip file attachment. Raytheon does not allow email attachments that
are considered likely to contain malicious code. For your protection this attachment has been
removed.

If this email is from an unknown source, please simply delete this email.

If this email was expected, and it is from a known sender, you may follow the below suggested
instructions to obtain these types of attachments.

+ Instruct the sender to enclose the file(s) in a ".zip" compressed file, and rename the ".zip"
compressed file with a different extension, such as, ".rtnzip".  Password protecting the renamed
".zip" compressed file adds an additional layer of protection. When you receive the file,
please rename it with the extension ".zip".

Additional instructions and options on how to receive these attachments can be found at:

http://security.it.ray.com/antivirus/extensions.html
http://security.it.ray.com/news/2007/zipfiles.html

Should you have any questions or difficulty with these instructions, please contact the Help
Desk at 877.844.4712

---

Hi

> What are you doing to build the .war, running an Ant script
> perhaps?
> 
> Does your build process include OS specific configuration?
> 
> Where are the OS specific configuration files you mentioned
> placed on
> the filing system?
> 
> What is different about the server.xml, in the two
> different Tomcat
> installations?
> 
> What do the logs says during startup in each Tomcat? 
> (You might clear
> the logs and start a fresh one for each server)

Yes, we do run an ANT script to build the war. The ANT script uses the build.properties file
that has couple of file system references. The build.xml, however does NOT have any such EXPLICIT
references. So, when I build the war it takes the jars and sources from the provided locations
and build at the provided target location. Now, I will re-iterate - 
1. I tried building the war in Windows and worked fine. I transferred the war to UNIX, it
mis-behaves as described earlier.
2. I tried building the war in UNIX, it mis-behaves as described earlier. I transferred the
war to Windows and it worked fine.

The config files are located in a directory structure, that directory location is provided
in the catalina.bat startup script. If they are not provided correctly, it will throw errors
while starting up the app. 

Windows and UNIX startup logs are attached herewith. I do not see any much difference in between
the logs except for the file systems.

Another additional comment - Its not only the back button that tends to display the Search
Result, a refresh of the page also displays the page properly. So, in short, click on search,
404-Page Not Found turns up. Refresh it, or Back Button of browser, Search result turns up.
This is the mis-behaviour in UNIX I have been mentioning.

Thanks and Regards,
Rahul

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message