tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pid <...@pidster.com>
Subject Re: Tomcat 6.0.26 with Java 6 update 20 on Sun Solaris 5.8 Sparc - Web application unable to execute properly
Date Thu, 01 Jul 2010 13:16:36 GMT
On 01/07/2010 13:34, rahul wrote:
> Hello Miki
> 
> Thanks for your inputs. UNIX war means the war file deployed in UNIX environment and
Windows war means the war file deployed in Windows. So, as I said that when I just transfer
the war file from Windows to UNIX, it mis-bheaves the way I specified. On the other hand,
if I transfer the war file from UNIX to Windows, it works perfectly. 
> 
> So, I guess that refutes the conception that the build process is platform dependent.
I can agree with the Tomcat Setup part. But what? I have been unable to figure that out for
this is the third day now.

What are you doing to build the .war, running an Ant script perhaps?

Does your build process include OS specific configuration?

Where are the OS specific configuration files you mentioned placed on
the filing system?

What is different about the server.xml, in the two different Tomcat
installations?

What do the logs says during startup in each Tomcat?  (You might clear
the logs and start a fresh one for each server)


p




> Thanks and Regards,
> Rahul
> 
> --- On Thu, 7/1/10, Mikolaj Rydzewski <miki@ceti.pl> wrote:
> 
>> From: Mikolaj Rydzewski <miki@ceti.pl>
>> Subject: Re: Tomcat 6.0.26 with Java 6 update 20 on Sun Solaris 5.8 Sparc - Web application
unable to execute properly
>> To: "Tomcat Users List" <users@tomcat.apache.org>
>> Date: Thursday, July 1, 2010, 4:05 PM
>> rahul wrote:
>>> 1. Replacing the Windows war file with the one in
>> UNIX, works fine. 2. Replacing the UNIX war file with that
>> in Windows mis-behaves.   
>> Please clarify what windows-war and unix-war mean.
>> So, in other words does it mean:
>>
>> If you take old war file, that runs on Tomcat 4.x, from
>> Solaris box and deploy it on new Tomcat on Windows box it
>> runs fine.
>>
>> If you build new war file on Windows box, deploy it on new
>> Tomcat on Windows box it runs fine. But if deploy the same
>> war file on new Tomcat on Solaris box it misbehaves.
>>
>> Is that correct?
>>
>> If so, I guess that either your build process is platform
>> dependant, or there are differences between Tomcat setups
>> (Windows vs Solaris).
>>
>> -- Mikolaj Rydzewski <miki@ceti.pl>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>
> 
> 
>       
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 



Mime
View raw message