tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jarosz Yohan <yohan.jar...@epfl.ch>
Subject deploying tomcat not on localhost
Date Thu, 15 Jul 2010 10:32:43 GMT
Hello,

I setup my production environment on Apache 2.2.14 and tomcat 6.0. 
I want to mount tomcat and all applications on a url like http://myServ.com/tomcat/(myApps)
Every things is working perfect when I set up tomcat on  http://myServ.com/(myApps) but this
will be reserved for another thing.
So, I have tried for apache configuration :

ProxyPass /tomcat/ balancer://tomcat stickysession=JSESSIONID|jsessionid nofailover=On 
<Proxy balancer://tomcat>                                                          
                                                                                         
                           
       BalancerMember ajp://localhost:7520                                               
                                                                                         
                     
</Proxy>

or with the balancer like that ajp://localhost:7520/tomcat/ (with http then I switch to ajp
protocol)

I have also tried 
JkMount /tomcat/* ajp13

and in server.xml file I have also tried to modify the defaultHost or add a virtual host with
no result...
every things is working perfectly when tomcat is on '/ '. I must be missing something....

thank you for help 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message