tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From puneet arora <puneet2...@yahoo.com>
Subject Issue with Eclipse 3.6, Tomcat 6/7 with Apache Myfaces 2.0
Date Sat, 24 Jul 2010 02:22:11 GMT
Hi All

I have defined a dynamic web project in Eclipse 3.6 to which i have added a user library that
has all the Myfaces 2.0 jars as well as the el-api-1.1 and el-impl-1.1 jars.

When i publish the project under wtp to the reference tomcat, i get the following startup
error:

java.lang.LinkageError: loader constraint violation: when resolving interface method "javax.servlet.jsp.JspApplicationContext.getExpressionFactory()Ljavax/el/ExpressionFactory;"
the class loader (instance of org/apache/catalina/loader/WebappClassLoader) of the current
class, org/apache/myfaces/webapp/Jsp21FacesInitializer, and the class loader (instance of
org/apache/catalina/loader/StandardClassLoader) for resolved class, javax/servlet/jsp/JspApplicationContext,
have different Class objects for the type javax/el/ExpressionFactory used in the signature

I have attached my catalina.out, web.xml and faces-config.xml... please help. Else please
point me to the right direction.

Puneet






Mime
View raw message