tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sravan Suryadevara <sravan.suryadev...@gmail.com>
Subject Running Perl in Tomcat
Date Thu, 10 Jun 2010 07:30:20 GMT
Hi,

So I'm trying run a perl script within tomcat. Since I need to run
only one script, I figured itd be easier to just include it in tomcat
than install Apache HTTP server.
I'm currently using Tomcat 6.0.26 on CentOS 5. I'm using port 8100
(has worked before the cgi stuff), and my webapp is running from ROOT.

I followed the howto at
http://tomcat.apache.org/tomcat-6.0-doc/cgi-howto.html and uncommented
the CGI servlet section and the servlet mapping.

Then I did made a new directory under
$CATALINA_HOME/webapps/ROOT/WEB-INF/ called cgi-bin.
Placed my script.cgi file in $CATALINA_HOME/webapps/ROOT/WEB-INF/cgi-bin

Then restarted tomcat. There are two problems:
1. http://localhost:8100/cgi-bin/script.cgi gives me a 404 saying
requested resource() is not available.
2. Another one of my html files does not load (it uses javascript) but
it has loaded before. My main html file still loads but that specific
one gives me a 404 as well.

I've been playing with different tutorials and things, but none seem
to be fixing this. Please help as quickly as you can.


Sincerely,
Sravan Suryadevara

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message