tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Still having problem retrieving user value from ISAPI Filter for authentication
Date Sun, 27 Jun 2010 20:55:50 GMT
Savoy, Melinda wrote:
> Let me ask another question if I might in addition to the one below:
> 
> In my ISAPI log it shows:
> 
> [Wed Jun 23 09:50:59.568 2010] [5024:6028] [debug] jk_isapi_plugin.c (3108): Service
protocol=HTTP/1.1 method=GET host=127.0.0.1 addr=127.0.0.1 name=localhost port=80 auth=NTLM
user=TEXAS\SavoyM uri=/index.jsp
> 
> The value of "80" is shown, my question is does this line in my ISAPI log show the request
as to where it is coming from, meaning IIS since IIS is on port 80?
> 
> My tomcat app is running on port 9080.
> 
> Just curious.
> 
> I think, I am going on to try Waffle, instead of trying to pursue this any further. 
dB has been kind enough to offer his help in getting me setup.
> 
> I just thought I'd ask this one last question. Thanks for all the time and help.
> 
Melinda,
you are doing something somewhere which you are not telling us.
Otherwise what you say you are doing should be working.
If the userid shows up in the isapi redirector log, then Tomcat is getting it, and you 
should see it with getRemoteUser().
If you are not seeing it, then there is something else, not originally belonging to the 
isapi redirector or Tomcat, which is overwriting it with a null.
If so, you will have the same issue with any authentication method.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message