tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pid <...@pidster.com>
Subject Re: Error on startup catalina
Date Fri, 04 Jun 2010 10:33:56 GMT
On 03/06/2010 19:06, Hassan Schroeder wrote:
> On Thu, Jun 3, 2010 at 10:08 AM, Pid <pid@pidster.com> wrote:
> 
>> If you take a fresh download and unzip it in a sub directory of your
>> user account, will it run there?
> 
> As a reference point -- here's a fresh install on a Mac/Snow Leopard system:
> 
> ripple:~/Downloads$ ls apache-tomcat-6.0.26.tar.gz
> -rw-r--r--  1 hassan  staff  6123410 Mar 17 13:18 apache-tomcat-6.0.26.tar.gz
> ripple:~/Downloads$ tar xfz apache-tomcat-6.0.26.tar.gz
> ripple:~/Downloads$ cd apache-tomcat-6.0.26
> ripple:~/Downloads/apache-tomcat-6.0.26$ export CATALINA_HOME=`pwd`
> ripple:~/Downloads/apache-tomcat-6.0.26$ ./bin/catalina.sh run
> Using CATALINA_BASE:   /Users/hassan/Downloads/apache-tomcat-6.0.26
> Using CATALINA_HOME:   /Users/hassan/Downloads/apache-tomcat-6.0.26
> Using CATALINA_TMPDIR: /Users/hassan/Downloads/apache-tomcat-6.0.26/temp
> Using JRE_HOME:
> /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home
> Using CLASSPATH:
> /Users/hassan/Downloads/apache-tomcat-6.0.26/bin/bootstrap.jar
> Jun 3, 2010 10:57:30 AM org.apache.catalina.core.AprLifecycleListener init
> INFO: The APR based Apache Tomcat Native library which allows optimal
> performance in production environments was not found on the
> java.library.path:
> /usr/local/ImageMagick-6.4.1/lib:/Users/hassan/Library/Oracle/instantclient_10_2:.:/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java
> Jun 3, 2010 10:57:30 AM org.apache.coyote.http11.Http11Protocol init
> INFO: Initializing Coyote HTTP/1.1 on http-8080
> Jun 3, 2010 10:57:30 AM org.apache.catalina.startup.Catalina load
> INFO: Initialization processed in 932 ms
> Jun 3, 2010 10:57:30 AM org.apache.catalina.core.StandardService start
> INFO: Starting service Catalina
> Jun 3, 2010 10:57:30 AM org.apache.catalina.core.StandardEngine start
> INFO: Starting Servlet Engine: Apache Tomcat/6.0.26
> Jun 3, 2010 10:57:30 AM org.apache.catalina.startup.HostConfig deployDirectory
> INFO: Deploying web application directory docs
> Jun 3, 2010 10:57:31 AM org.apache.catalina.startup.HostConfig deployDirectory
> INFO: Deploying web application directory examples
> Jun 3, 2010 10:57:31 AM org.apache.catalina.startup.HostConfig deployDirectory
> INFO: Deploying web application directory host-manager
> Jun 3, 2010 10:57:31 AM org.apache.catalina.startup.HostConfig deployDirectory
> INFO: Deploying web application directory manager
> Jun 3, 2010 10:57:31 AM org.apache.catalina.startup.HostConfig deployDirectory
> INFO: Deploying web application directory ROOT
> Jun 3, 2010 10:57:31 AM org.apache.coyote.http11.Http11Protocol start
> INFO: Starting Coyote HTTP/1.1 on http-8080
> Jun 3, 2010 10:57:31 AM org.apache.jk.common.ChannelSocket init
> INFO: JK: ajp13 listening on /0.0.0.0:8009
> Jun 3, 2010 10:57:31 AM org.apache.jk.server.JkMain start
> INFO: Jk running ID=0 time=0/20  config=null
> Jun 3, 2010 10:57:31 AM org.apache.catalina.startup.Catalina start
> INFO: Server startup in 1384 ms
> 
> After confirming it basically works, I would normally cd out and move
> the tomcat directory to /usr/local and set CATALINA_HOME to the
> appropriate value.
> 
> HTH!

Yep works first time on my mac too.


p




Mime
View raw message