tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pid <...@pidster.com>
Subject Re: Error on startup catalina
Date Thu, 03 Jun 2010 10:42:46 GMT
On 02/06/2010 22:33, Sandro Gallo wrote:
> Hi,
> Using recently Tomcat.
> So far I have used it on a Windows XP machine, and everything went well.
> I decided to install it on a machine Mac, Mac OS X Snow Leopard, but can
> not boot.
> I do not know how to solve the problem, and I need to use Tomcat.
> Please, help me.
> Here are some info on startup:
> 
> *Using CATALINA_BASE: /Library/Tomcat/Home
> Using CATALINA_HOME: /Library/Tomcat/Home
> Using CATALINA_TMPDIR: /Library/Tomcat/Home/temp
> Using JRE_HOME: /Library/Java/Home
> Using CLASSPATH: /Library/Tomcat/Home/bin/bootstrap.jar
> at org.apache.catalina.startup.Bootstrap.<clinit>(Bootstrap.java:55)
> Caused by: java.lang.ClassNotFoundException:
> org.apache.juli.logging.LogFactory
> at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
> at java.security.AccessController.doPrivileged(Native Method)
> at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
> at sun.misc.Launcher$ExtClassLoader.findClass(Launcher.java:244)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:315)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:250)
> at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:398)
> ... 1 more
> *
> 
> Thanks in advance.

Did you need to authenticate to install files in /Library?

Which user are you using when you attempt to start Tomcat?


p


Mime
View raw message