tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Is Tomcat Connector for IIS (isapi_redirect.dll) tested/supported on W2k8 64-bit?
Date Thu, 20 May 2010 16:04:34 GMT
Hi.

If you are using isapi_redirect.dll together with a 64-bit IIS, then you 
probably need a 64-bit isapi_redirect.dll.
Is that what you are using ?


Ganesan, Chandru wrote:
> Hi
> 
> Please see the email below for the problem description.
> 
> 
> 1.      Is isapi_redirect.dll tested/supported on Windows 2008 64-bit?
> 
> 2.      I'm able to successfully hit the tomcat server when IIS 7 is configured to run
in 32-bit mode on Win2k8 (64-bit). IIS trace shows following error when I use 64-bit mode.
> FileName
> 
> C:\inetpub\wwwroot\test\test.jsp
> 
> 
> ErrorCode
> 
> 2147942403
> 
> 
> ErrorCode
> 
> The system cannot find the path specified. (0x80070003)
> 
> 
> 
> 3.      How do I know, on IIS 7,  if isapi_redirect.dll is being hit?  Tasklist command
doesn't display the isapi_redirect.dll file even when it is working under 32-bit mode. IIS
6 has documented steps to verify this, however this has been removed in IIS 7.
> 
> 4.      No matter whether the isapi_redirect.dll is present or not, above error is always
displayed.
> 
> Appreciate your input very much.
> 
> Thanks
> Chandru Ganesan
> From: Ganesan, Chandru
> Sent: Wednesday, May 19, 2010 9:16 AM
> To: Tomcat Users List
> Subject: Problem with IIS 7.0 plugin isapi_redirect on Windows 2008 64 bit
> 
> Hi
> 
> I'm trying to configure the IIS 7.0 with latest isapi_redirect.dll (Ver 1.2.30) on Windows
2008 Server (64 bit). When I try to login to the Apache Tomcat 5.5 Servlet container, it fails
with
> the error:
> 
> 404 - File or directory not found.
> The resource you are looking for might have been removed, had its name changed,
> or is temporarily unavailable.
> 
> Also I don't see any logs getting generated in isapi.log file, so I'm at a loss
> as to the root cause of this issue. I don't see isapi_redirect.dll getting loaded, however
I notice isapi.dll being loaded.
> 
> 
> Attaching isapi_redirect.properties file below. Thanks in advance for your input.
> 
> 
> # The path to the ISAPI Redirector Extension, relative to the website
> # This must be in a virtual directory with execute privileges
> extension_uri=/jakarta/isapi_redirect.dll
> 
> # Full path to the log file for the ISAPI Redirector
> log_file=c:\inetpub\scripts\isapi.log
> 
> # Log level (debug, info, warn, error or trace)
> log_level=debug
> 
> # Full path to the workers.properties file
> worker_file=c:\Inetpub\scripts\workers.properties
> 
> # Full path to the uriworkermap.properties file
> worker_mount_file=c:\Inetpub\scripts\uriworkermap.properties
> 
> rewrite_rule_file=c:\Inetpub\scripts\rewrites.properties
> 
> Thanks
> Chandru Ganesan
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message