tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Filchak <sub...@zuka.net>
Subject Tomcat on a machine with multiple ip addresses
Date Sun, 02 May 2010 19:35:21 GMT
Due to a hard drive failure, I am needing to move some websites to a 
machine that has Tomcat already running on it with Apache as the front 
end. I was unable to get the sites working using the Apache instance 
that was already there so, I installed a second instance on the machine, 
with a separate pid and listening on a different ip. ( it would have 
been better to just use the same Apache instance but I could not get it 
to work. The default Tomcat page kept coming up) I added the address 
attribute to the server.xml files so that it would not listen on all 
interfaces. So, I have the new instance sort of working but for some 
reason, on all but two virtual sites, I cannot access them if I use 
www.somedomain.com. Only if I use somedomain.com. As I said, two of the 
sites work fine. The dns resolves correctly to either www.somedomain.com 
or somedomain.com. So, can tomcat or could tomcat be screwing this up 
somehow (actually, I guess it would have been me who screwed it up 
somewhere). I am not well versed in tomcat at this point so some help 
would be greatly appreciated. Either just to solve this issue or help on 
how I could have simply used the original instance to server my 
non-tomcat php sites.

Thanks in advance.

Dave

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message