tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Trouble accessing content in webapps/ROOT
Date Thu, 15 Apr 2010 17:15:45 GMT
2010/4/15 laredotornado <laredotornado@gmail.com>:
>
> Hi,
>
> I'm using Tomcat 6.0.26 with Apache 2.2 on Mac 10.6.3.  I want to use
> http://localhost/ to access content in my $CATALINA_HOME/webapps/ROOT/
> directory.  However, when I visit http://localhost/index.jsp, I just get the
> raw page with all the uncompiled, JSP code.  Below is the directive I'm
> using in my httpd.conf file.  Any thoughts?
>

Yes, your configuration is wrong.

Have you read the manuals,  I mean the proper ones at
http://tomcat.apache.org/ ?

There should be a warning somewhere, that you must not point Apache to
your Tomcat appbase. (Pointing it to your ROOT application is a lesser
"crime", but still similar to the original one).

>
>  DocumentRoot "/Library/Tomcat/Home/webapps/ROOT"
>  <Directory "/Library/Tomcat/Home/webapps/ROOT">
>    Options Indexes FollowSymLinks
>    AllowOverride None
>    Order allow,deny
>    Allow from all
>  </Directory>
>  JkMount (...)
>
> I am successfully able to access JSP content in other webapps directories
> other than ROOT.  Thanks, - Dave
>

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message