tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filipe Névola <filipe...@gmail.com>
Subject Tomcat slow to start
Date Sun, 18 Apr 2010 04:12:39 GMT
Good evening, I have a problem that several people have asked for and posted
on some forums and got no answer to solve.

There goes the problem:

I'm using Tomcat 6.0.24, JSF 1.2, Rich Faces, a4j, JPA and Hibernate and
after adding the a4j and Rich faces in my application the Tomcat is taking
too long to start. Everything is running smoothly, including the rich faces
and a4j.

See the schedules in bold LOG:

17/04/2010 22:05:06 org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal
performance in production environments was not found on the
java.library.path: C:\Arquivos de
programas\Java\jre6\bin;.;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:/Arquivos
de programas/Java/jre6/bin/client;C:/Arquivos de
programas/Java/jre6/bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Arquivos
de programas\TortoiseSVN\bin;C:\Arquivos de
programas\QuickTime\QTSystem\;C:\Arquivos de programas\Microsoft Visual
Studio\Common\Tools\WinNT;C:\Arquivos de programas\Microsoft Visual
Studio\Common\MSDev98\Bin;C:\Arquivos de programas\Microsoft Visual
Studio\Common\Tools;C:\Arquivos de programas\Microsoft Visual
Studio\VC98\bin;C:\Arquivos de programas\OpenVPN\bin
17/04/2010 22:05:06 org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting
property 'source' to 'org.eclipse.jst.jee.server:Emprego' did not find a
matching property.
17/04/2010 22:05:06 org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
17/04/2010 22:05:06 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 652 ms
17/04/2010 22:05:06 org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
*17/04/2010 22:05:06* org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.24
*17/04/2010 22:05:45 *org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
17/04/2010 22:05:45 org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
17/04/2010 22:05:45 org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/62  config=null
17/04/2010 22:05:45 org.apache.catalina.startup.Catalina start
INFO: Server startup in *38987 *ms

It takes a long this line:
INFO: Starting service Catalina
*17/04/2010 22:05:06* org.apache.catalina.core.StandardEngine start

Seen this happen? I'm suspicious of any conflicting setting.

Attached the web.xml and faces-config.xml from my application.

Well, if you need more details of the application can send.

Thank you!
---
Att. Filipe Areias Névola
Java Analyst Developer

E-mail: filipenevola@gmail.com
MSN: filipenevola@gmail.com
gTalk: filipemkv@gmail.com
Skype: filipenevola

Founder and Writer Blog http://www.allgoritmos.com
Contributor JavaFree.org

"No eye has seen, nor ear heard, neither have entered into the human heart
that God has prepared for those who love him." (1 Corinthians 2:9)

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message