tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Klemens Muthmann <klemens.muthm...@tu-dresden.de>
Subject Mod_jk 1.2.26 + tomcat 6.0.26 + apache 2.2.12 not working on ubuntu 'karmic'
Date Fri, 23 Apr 2010 15:21:00 GMT
Hi

I hope this is the correct mailing list for this question. I have a 
problem setting up the configuration as described in the subject of this 
mail. I did the following:

- Installed apache2 from the ubuntu repository (synaptic states the 
version as 2.2.12-1ubuntu2.2)
- Installed mod_jk from the ubuntu repository (synaptic states the 
version as 1:1.2.26-2.1)
- Installed tomcat 2.0.26 manually (just unzipped the package from the 
download area to /opt)

Individually apache and tomcat run fine and both make several web 
applications (apache: mantis, myphpadmin and wordpress; tomcat: hudson 
and nexus) available. However now I need to make the tomcat applications 
available over port 80 so I tried to configure mod_jk but it does not 
work. I already did this successfully several years ago under Windows 
but with these Ubuntu packages I am already trying the whole day without 
any real progress.

Currently the configuration looks like:
- There is a symbolic link to jk.load file in /etc/apache2/mods-enabled 
with content:
    LoadModule jk_module /usr/lib/apache2/modules/mod_jk.so

- httpd.conf is loaded in apache2.conf (after jk.load) via: "Include 
/etc/apache2/httpd.conf" and has the following content:
    JkWorkersFile   /etc/libapache2-mod-jk/workers.properties
    JkLogFile       /var/log/apache2/mod_jk.log
    JkLogLevel      debug
    JkMount /nexus/* ajp13_worker

- workers.properties is in /etc/libapache2-mod-jk
    workers.tomcat_home=/opt/tomcat26
    workers.java_home=/usr/lib/jvm/java-6-openjdk
    ps=/
    worker.list=ajp13_worker
    worker.ajp13_worker.port=8009
    worker.ajp13_worker.host=localhost
    worker.ajp13_worker.type=ajp13
    worker.ajp13_worker.lbfactor=1
    worker.loadbalancer.type=lb
    worker.loadbalancer.balance_workers=ajp13_worker

I checked the connector port in tomcats server.xml. It is the correct 
one (8009) for ajp13. But I get no access to the nexus application on 
port 80 (also tried several different URL patterns with JkMount). So I 
turned on debugging output for the mod_jk.log. There is much output, but 
I think the relevant error messages are:
    [Fri Apr 23 15:20:05.210 2010] [23365:3585353520] [debug] 
jk_translate::mod_jk.c (3038): missing uri map for 127.0.1.1:/nexus/
    [Fri Apr 23 15:20:05.210 2010] [23365:3585353520] [debug] 
jk_map_to_storage::mod_jk.c (3195): missing uri map for 127.0.1.1:/nexus/
There I am at the end of my wits. I have absolutely no idea what these 
messages mean and Google produces no helpful tipps either. Does anyone 
on this list have any ideas?

Regards
    Klemens




Mime
View raw message