tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clark <cmwri...@rampageinc.com>
Subject Re: Significant change between 5.5 and 6.0 for Development
Date Thu, 01 Apr 2010 21:31:45 GMT
On 4/1/2010 5:23 PM, Pid wrote:
> On 01/04/2010 21:52, Clark wrote:

The context.xml is in <app-base>/ROOT/META-INF

The server.xml, for both 5.5 and 6.0, is :

<<Server port="*8005*" shutdown="*SHUTDOWN*">
- <#> <GlobalNamingResources>
<Resource name="*UserDatabase*" auth="*Container*" 
type="*org.apache.catalina.UserDatabase*" description="*User database 
that can be updated and saved*" 
factory="*org.apache.catalina.users.MemoryUserDatabaseFactory*" 
pathname="*conf/tomcat-users.xml*" />
</GlobalNamingResources>
- <#> <Service name="*Catalina*">
<Connector port="*80*" protocol="*HTTP/1.1*" connectionTimeout="*20000*" 
redirectPort="*443*" />
<Connector port="*8009*" protocol="*AJP/1.3*" redirectPort="*8443*" />
- <#> <Engine name="*Catalina*" defaultHost="*localhost*">
<Realm className="*org.apache.catalina.realm.UserDatabaseRealm*" 
resourceName="*UserDatabase*" />
<Host name="*localhost*" appBase="*webapps*" unpackWARs="*true*" 
autoDeploy="*true*" xmlValidation="*false*" xmlNamespaceAware="*false*" />
- <#> <Host name="*192.168.2.52*" 
appBase="*C:/Users/Clark/Workspaces/Sandbox/Java/Mainline/RampageRemoteVersion_1/WebRoot*"

unpackWARs="*false*" autoDeploy="*true*">
<Alias>192.168.2.52</Alias>
</Host>
</Engine>
</Service>
</Server>

And yes, I know the <alias>...</alias> is redundant.

As stated, for 5.5 this configuration works just fine.

In 6.0, it works, but is rather touchy, problematic and somewhat self 
destructive.

Thanks,

- clark.


>>
>> We recently started looking at moving from Tomcat 5.5.28 to 6.0.26 in
>> our development environment.
>>
>> In the initial upgrade/testing of it, I have found the following that
>> gives me great concern.
>>
>> Again, this is in a development sandbox, not a production deployment.
>> The environment, btw, is Eclipse 3.5, MyEclipse 8.5, Java 1.6, 
>> Windows 7.
>>
>> We run our app as the ROOT context, using this context.xml, and the
>> appbase is set to be the developers working sandbox in the server.xml
>>
>> <Context path="" docBase="" reloadable="true">
>
> The above is defined in a context.xml file?  If so, where is the file 
> placed - because it looks broken to me...
>
>> <Logger className="org.apache.catalina.logger.FileLogger"
>> prefix="inhouse."
>> suffix=".log" timestamp="true"/>
> >
>> <Resource name="jdbc/rampage" auth="Container"
>> type="javax.sql.DataSource"
>> url="jdbc:mysql://192.168.2.52:3306/Rampage"
>> factory="com.rampageinc.EncryptedDataSourceFactory"
>> driverClassName="com.mysql.jdbc.Driver"
>> username="uuuuu"
>> password="ppppp"
>> maxIdle="5"
>> maxActive="50"
>> />
>>
>> <Environment name="company.id" value="0" type="java.lang.Long"
>> override="false"/>
>> <Environment name="site.id" value="0" type="java.lang.Integer"
>> override="false"/>
>> <Environment name="timeout.interval" value="3600"
>> type="java.lang.Integer" override="false"/>
>>
>> <Environment name="service.jobs"
>> value="com.rampageinc.services.JobService" type="java.lang.String"
>> override="false"/>
>> <Environment name="service.useraccesscontrol"
>> value="com.rampageinc.services.UserAccessControlService"
>> type="java.lang.String" override="false"/>
>> <Environment name="service.cms"
>> value="com.rampageinc.services.CMSService" type="java.lang.String"
>> override="false"/>
>> <Environment name="root.upload" value="C:\TempUpload"
>> type="java.lang.String" override="false"/>
>> <Environment name="root.job" value="\\Winserve-2008\Clark-12-0\Rsi
>> Jobs" type="java.lang.String" override="false"/>
>> <Environment name="root.db"
>> value="\\Winserve-2008\Clark-12-0\Rampage" type="java.lang.String"
>> override="false"/>
>> <Environment name="root.preps"
>> value="\\Winserve-2008\Clark-12-0\Preps 5.2" type="java.lang.String"
>> override="false"/>
>> </Context>
>>
>> And it loads just fine.
>
> It loads just fine in Tomcat 6?
>
> What do you have in your server.xml for 5.5 and 6.0?
>
>
> p
>
>
>> Here are the problems with 6.0:
>>
>> 1. While running, hot deploy does not work. Changes made to the app are
>> not picked up consistently. In specific, class file changes appear to be
>> missed.
>> 2. If you stop Tomcat, change the app, and start Tomcat, the app does
>> not load. You have to manually delete the copied ROOT.xml from under
>> conf/Catalina/localhost
>> 3. If you delete the ROOT.xml while tomcat is running, it deletes the
>> appbase directory. Since this is pointing to the developers sandbox...
>>
>> None of these happen with 5.5 and earlier.
>>
>> Since any one of these would be a full stop issue for developing under
>> Tomcat 6.0, this is just hitting the Trifecta of badness.
>>
>> So, is it that we have missed some new configuration parameter?
>
>
>
>> This also appears to be related to Bug 47343 (introduced by 42747).
>>
>> In the mean time, back to 5.5.28.
>>
>> - Clark Wright.
>
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>
>
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message