tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Armbrust <daniel.armbrust.l...@gmail.com>
Subject Re: [OT] Re: jvm exits without trace
Date Mon, 22 Mar 2010 18:17:09 GMT
On Tue, Mar 16, 2010 at 4:46 PM, Carl <carl@etrak-plus.com> wrote:
> My approach is to get something (a JVM) that works and then gradually change
> until it breaks.  Then, I know what is causing the problem.  To date, I
> haven't been able to get a JVM that works.
>

I have had a lot of issues finding stable JVMs since I moved our
software from 1.5 to 1.6... 1.6 has been a mess for ages under our
workload on CentOS.  Code that ran fine under 1.5 would segfault in
all sorts of random places on 1.6.  I even tried the 1.7 openJDK early
builds... they were even worse.

I was pleased to see that the most recent release
http://java.sun.com/javase/6/webnotes/6u18.html contains _tons_ of bug
fixes, including lots of crash fixes.  Seriously... the last few
releases have contained only a handful of fixes... this release has
hundreds.

I'm testing it now, and so far, it looks promising.  This may be the
first 1.6 release that I've found that doesn't crash with my workload.
Unfortunately, I've never been able to pin down a sequence of events
that would cause the crash on demand, so its hard for me to verify
that things are finally fixed, other than doing long term load testing
and waiting for the crashes to (hopefully) not happen.

Dan

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message