tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mladen Turk <mt...@apache.org>
Subject Re: mod_jk 1.2.30 error problem after upgrade
Date Thu, 18 Mar 2010 06:56:15 GMT
On 03/17/2010 09:35 PM, Anthony J. Biacco wrote:
> I may have found it from 5 minutes earlier, I didn't go back that far in
> the log. I'll mail it privately, I don't feel comfortable posting the
> content in whole publicly, if that's alright.
>

OK. Here is the problem

Send request header
[Wed Mar 17 09:45:14 2010] [521:1221798208] [debug] ajp_send_request::jk_ajp_common.c (1639):
(tr1) request body to send 6815 - request body to resend 0

Since this is POST mod_jk sends immediately the first body chunk of post data
[Wed Mar 17 09:50:14 2010] [521:1221798208] [debug] ajp_send_request::jk_ajp_common.c (1744):
(tr1) sending 5840 bytes of request body

However notice that there is 5 minutes gap between the actual data
has been read from the client and send to the tomcat.
By that time tomcat already closed the connection (30 seconds in server.xml) and then
any request to send the data fails. Actually all sockets shut down.

E.g
[Wed Mar 17 09:50:14 2010] [521:1221798208] [debug] jk_is_input_event::jk_connect.c (986):
error event during poll on socket sd = 68 (event=24)

This means the read side has been down.

[Wed Mar 17 09:50:14 2010] [521:1221798208] [debug] jk_shutdown_socket::jk_connect.c (730):
Failed sending SHUT_WR for socket 68

... and even write side.


So, seems like you have very slow client, so try to enlarge the timeouts
or find the reason for slow clients.

Also why are you using recovery_options = 4 ?



Regards
-- 
^TM

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message