tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Installation differences between 6.0.24 and 5.5.28
Date Mon, 08 Mar 2010 20:15:49 GMT
David kerber wrote:
> I've run into this before, but didn't have time to hunt down the issue. 
> Now I do, so here goes.
> 
> I have installed both TC 6.0.24 and 5.5.28 on Windows server 2003 32-bit 
> (into separate directories, of course).  In each case, I first ran the 
> windows installer .exe, and then unzipped the .zip package on top of it 
> so I would have the service.bat utilities.  Each one started its default 
> service with no trouble.
> 
> I then created a service for my app with each version's service.bat 
> (different names), which starts from a separate folder on the HD.  With 
> IDENTICAL settings, both pointing to the exact same catalina_base, the 
> 5.5 one starts fine, and 6.0 fails to start, with the following error in 
> stderr_20100308.log:
> 
> java.lang.ClassNotFoundException: org.apache.catalina.startup.Catalina
>     at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
>     at java.security.AccessController.doPrivileged(Native Method)
>     at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
>     at java.lang.ClassLoader.loadClass(ClassLoader.java:303)
>     at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
>     at org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:216)
>     at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:391)
> 
> 
> 
> Much searching of documentation and faqs has not turned up an 
> explanation of what I may be missing in the 6.0 installation, or what 
> the configuration differences are between the two versions.
> 
> Any suggestions?

I'll take a pot-shot :
If I compare my Tomcat 5.5 and 6.0 catalina_home dirs, I see that in 5.5 
there is a "shared" subdir, with 2 subdirs "classes" and "lib".
On the other hand, under 6.0 there is no "shared" subdir, only a "lib".
If these sub-directories were defined as being relative to 
catalina_base, that may explain your problem, no ?
(In the sense that Tomcat6.0 is looking for a class under the 
catalina_base/lib subdir, but there is no such thing)

(If I understand well what you say above, catalina_base is really one 
one and the same directory, used for both your tomcat5.5 and tomcat6.0 
trials, yes ?)


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message