tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dale77 <Dale.Ogil...@trimble.co.nz>
Subject Tomcat 6.0.18 fails to load webapp on container restart
Date Tue, 02 Mar 2010 21:09:15 GMT

Hi,

The application loads first time, but if tomcat is restarted, the app fails
with the the following error:

INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
Feb 23, 2010 8:42:54 AM org.apache.catalina.core.StandardContext
resourcesStart
SEVERE: Error starting static Resources
java.lang.IllegalArgumentException: Document base C:\Program Files\Apache
Software Foundation\Tomcat 6.0\webapps\services\myapp does not exist or is
not a readable directory
	at
org.apache.naming.resources.FileDirContext.setDocBase(FileDirContext.java:141)
	at
org.apache.catalina.core.StandardContext.resourcesStart(StandardContext.java:3957)
	at
org.apache.catalina.core.StandardContext.start(StandardContext.java:4126)
	at
org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
	at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
	at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:525)
	at
org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:627)
	at
org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:553)
	at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:488)
	at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1149)
	at
org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
	at
org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
	at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
	at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
	at org.apache.catalina.core.StandardService.start(StandardService.java:516)
	at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
	at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)

The application is packaged as services#myapp.jar, and has a
META-INF/context.xml containing a single <ResourceLink> tag. When the app is
deployed, this expands the jar into webapps/services#myapp and copies
context.xml to conf/Catalina/localhost/services#myapp.xml

The app runs fine at this point. If tomcat is restarted however, the error
occurs because the directory does indeed not exist, it is looking for the
wrong directory. It should be looking for "C:\Program Files\Apache Software
Foundation\Tomcat 6.0\webapps\services#myapp".

If I delete conf/Catalina/localhost/services#myapp.xml, the app starts fine,
until the next tomcat restart.

Is this a bug with tomcat? Any workarounds?

Thanks

Dale
-- 
View this message in context: http://old.nabble.com/Tomcat-6.0.18-fails-to-load-webapp-on-container-restart-tp27761207p27761207.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message