tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carl" <c...@etrak-plus.com>
Subject Re: [OT] Re: jvm exits without trace
Date Tue, 23 Mar 2010 01:04:27 GMT
George,

I tried OpenSuSE with 6u17 and the results were about the same as Slackware 
64 so the implication is that there is something in my app that is 
triggering the seg fault.  My app is mostly jsp's running against MySQL with 
some AJAX and Flash (communicating through a servlet.)  I do not use any 
native code nor do I use AJP.  I do use SSL for everything.  It has also 
failed on different hardware although the OS was the same.

The argument against the problem being in my app is that the app runs fine 
(has for several years) on 32 bit Slackware and it now seems to be running 
fine on 6u7 (on Slackware 64.)

Now that I appear to have a stable system that I can always go back to, I 
would like to get to the root cause.  My thought was that I could get the 
source code, compile it on the server and then wait for it to fail with a 
core file that could give me the answer (maybe.)  However, I can only find 
source code for the 'open' fork which may or may not be the same so I am 
stymied again.

I guess I just have to keep stabbing in the dark with the new JVM's until 
one happens to work... not very scientific.

Thanks,

Carl


----- Original Message ----- 
From: "George Sexton" <georges@mhsoftware.com>
To: "'Tomcat Users List'" <users@tomcat.apache.org>
Sent: Monday, March 22, 2010 2:48 PM
Subject: RE: [OT] Re: jvm exits without trace


> -----Original Message-----
> From: Dan Armbrust [mailto:daniel.armbrust.list@gmail.com]
> Sent: Monday, March 22, 2010 12:17 PM
> To: Tomcat Users List
> Subject: Re: [OT] Re: jvm exits without trace
>
> On Tue, Mar 16, 2010 at 4:46 PM, Carl <carl@etrak-plus.com> wrote:
> > My approach is to get something (a JVM) that works and then gradually
> change
> > until it breaks. Then, I know what is causing the problem. To date,
> I
> > haven't been able to get a JVM that works.
> >
>
> I have had a lot of issues finding stable JVMs since I moved our
> software from 1.5 to 1.6... 1.6 has been a mess for ages under our
> workload on CentOS.  Code that ran fine under 1.5 would segfault in
> all sorts of random places on 1.6.  I even tried the 1.7 openJDK early
> builds... they were even worse.
>
> I was pleased to see that the most recent release
> http://java.sun.com/javase/6/webnotes/6u18.html contains _tons_ of bug
> fixes, including lots of crash fixes.  Seriously... the last few
> releases have contained only a handful of fixes... this release has
> hundreds.

I'm running 1.6.0_18 under OpenSuSE 11.0-11.2 and I've only had one problem.
It looks like a GLIBC error related to IPV6. I disabled IPV6 on the machine
and it's been rock solid since.

I don't use native connectors, or AJP. I do about 900,000 hits with 4GB/Day
spread across 3 servers and it's just rock steady. I run the tomcat
instances for 2-3 weeks each before re-starting. For each machine, that's
about 6 million hits with about 40 GB of transfer.

George Sexton
MH Software, Inc.
303 438-9585
www.mhsoftware.com


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message