tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lonnie Lewis <lonnie.le...@gmail.com>
Subject Trouble accessing application resources from default web app
Date Tue, 02 Feb 2010 00:05:25 GMT
I have an application I've deployed to a 5.5 server. It works fine if using
the application name in the URL:

http://.../myApp

However I would like it to be my default application so I've edited the
ROOT.xml file as:
<Context docBase="${catalina.home}/server/webapps/LifeSim" />

The application come up fine (the home page) by not supplying the "myApp"
context. However, the CSS and JavaScript files aren't loaded. I'm specifying
them like:

<script type="text/javascript"
src="${request.contextPath}/js/default.js"></script>

I've also tried:

<script type="text/javascript"
src="${pageContext.request.contextPath}/js/default.js"></script>

The contextPath is always blank. It makes sense as there isn't a contextPath
supplied in the URL, but how can I get this to work? I've tried supplying a
"path" in the Context specification, but I can't get that to work either.

Thanks


-- 
Lonnie Lewis

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message