tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: Still unable to get a heap dump from Tomcat running on Windows as a service
Date Tue, 02 Feb 2010 22:04:03 GMT
> From: Laird Nelson [mailto:ljnelson@gmail.com]
> Subject: Re: Still unable to get a heap dump from Tomcat running on
> Windows as a service
> 
> I'm not a Windows guy, so bear with me for a moment:

I'm not sure there's anyone who really understands Windows security.

> Or is there some other privilege setting that says even if there's
> permission granted to the filesystem, the system account shalt not
> write even unto it?

Windows security settings are truly bizarre, and the Local System Account is subject to restrictions
that don't seem to make any sense.  It certainly *can* write some files, otherwise Tomcat
wouldn't be able to function at all.  BTW, on Vista, you can't seem to change the account
the Tomcat service runs under with the GUI tool - it has to be done with the Administrative
Tools -> Services snapin; don't know if that's true for Server 2K3.

I just tried forcing an OOME dump with Tomcat running under the Local System Account - and
it worked.  This is under Vista 64, not Server 2K3, and starting with the .zip download.

You could always try downloading and installing the .zip version in an alternate location,
and install the service under an alternate name just for testing.  I don't have access to
a Server 2K3 system to play with.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus
for use only by the intended recipient. If you received this in error, please contact the
sender and delete the e-mail and its attachments from all computers.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message