tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: [Fwd: Re: Parameters disappear from PUTs]
Date Fri, 05 Feb 2010 22:35:47 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Chas,

On 2/5/2010 2:45 PM, chas@munat.com wrote:
> So for Tomcat to unilaterally strip the entity-headers from a PUT request
> while passing only the optional entity-body seems just, well, wrong to me.

Could you please be clear when you say "entity headers": do you mean
HTTP headers? I have a Tomcat 6.0.20 install right in front of me that
definitely does allow the servlet (in my case, a simple JSP that dumps
requests) to read the HTTP headers. HTTP GET parameters are also
correctly provided to the servlet.

> example.com/persons/6cd79223-3585-4618-ab78-1c20db09c535

I didn't check to see if the path info is available for PUT requests.
For that, I'll have to write a separate servlet. I'm willing to write a
test if this is the behavior you are experiencing.

So, please, what is it that Tomcat is apparently hiding from your servlet?

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAktsnUMACgkQ9CaO5/Lv0PBmaACghka+Yd/kqKmhgKcuaLRQED6q
FvQAn3/6JsutlG4NEEYf8u0sCThfO04w
=7yzW
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message