tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Apache Tomcat/httpd websites problem ?
Date Sat, 13 Feb 2010 15:40:07 GMT
2010/2/13 André Warnier <aw@ice-sa.com>:
> Hi.
>
> Does anyone else experience problems accessing the Apache websites right now
> ?
> I am getting "Invalid Encoding" errors in Firefox 3.5.
>
> Content Encoding Error
> The page you are trying to view cannot be shown because it uses an invalid
> or unsupported form of compression.
>
> I would suspect a local problem, but Google, IBM and other pages seems to
> load fine.  IE also is unable to access the Apache pages.
>
> At further inspection, it seems to be due to an invalid gzip-encoded
> response.
>
>
> Example, captured using HttpFox browser plugin :
>
> Request :
> (Request-Line)  GET /tomcat-6.0-doc/index.html HTTP/1.1
> Host    tomcat.apache.org
> User-Agent      Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.3)
> Gecko/20090824 Firefox/3.5.3
> Accept  text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
> Accept-Language en-gb,en;q=0.5
> Accept-Encoding gzip,deflate
> Accept-Charset  ISO-8859-1,utf-8;q=0.7,*;q=0.7
> Keep-Alive      300
> Connection      keep-alive
> Range   bytes=1-
> If-Range        "d10ded-31ff-47d84a38e2700-gzip"
> Cache-Control   max-age=0
>
> Response :
> (Status-Line)   HTTP/1.1 200 OK
> Date    Sat, 13 Feb 2010 14:23:13 GMT
> Server  Apache/2.3.5 (Unix) mod_ssl/2.3.5 OpenSSL/0.9.7d mod_fcgid/2.3.2-dev
> Last-Modified   Tue, 19 Jan 2010 13:42:20 GMT
> Etag    "d10ded-31ff-47d84a38e2700-gzip"
> Accept-Ranges   bytes
> Vary    Accept-Encoding
> Content-Encoding        gzip
> Content-Range   bytes 1-12798/12799
> Content-Length  12798
> Keep-Alive      timeout=30, max=100
> Connection      Keep-Alive
> Content-Type    text/html
>
> Status line in HttpFox plugin :
>
> 00:02:23.326    0.179   483     13101   GET     200     text/html
> (NS_ERROR_INVALID_CONTENT_ENCODING)
> http://tomcat.apache.org/tomcat-6.0-doc/index.html
>

(resending, as the original message didn't reach all the recipients)

Yes, I am also seeing this error. I am using Firefox 3.6.

It occurs only with EU mirror of the site. The US mirror is running fine.

http://tomcat.eu.apache.org/
http://tomcat.us.apache.org/

More than that, the error is intermittent: refreshing the page I get

a) "Invalid Encoding" error
b) misrendered page (site search box is aligned to the left border of
the screen) (probably the stylesheet failed to load)
c) correctly rendered page


>From an error page footer I see that the EU server runs Apache/2.3.5,
while US one uses Apache/2.3.3

Apache/2.3.5 (Unix) mod_ssl/2.3.5 OpenSSL/0.9.7d mod_fcgid/2.3.2-dev
Server at tomcat.apache.org Port 80
Apache/2.3.3 (Unix) mod_ssl/2.3.3 OpenSSL/0.9.7d mod_fcgid/2.3.2-dev
Server at tomcat.us.apache.org Port 80


Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message