tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Laird Nelson <>
Subject Still unable to get a heap dump from Tomcat running on Windows as a service
Date Tue, 02 Feb 2010 20:53:42 GMT
I am still unable to get Tomcat to dump heap when it encounters an
OutOfMemoryError.  My StackOverflow topic sums up what I've tried so far:

I'm using the graphical program that comes up when you select "Monitor
Tomcat" from the Windows Start Menu.  I assume this is TomcatW.exe?

I have Tomcat 6.0.20 running as a service under the default local user
account, set to be allowed to interact with the desktop (I don't know if
this is necessary; I've tried it both ways with no effect on the outcome).

I've attempted to switch the startup mode to "java" from "jvm" to see if
that would make a difference, but in that case the service simply won't

I've specified -XX:HeapDumpPath=C:\crap, and -XX:HeapDumpPath=C:/crap to no
avail.  C:\crap is world readable and writable.

I've set the working path for the Startup and Shutdown tabs to C:\crap and
C:/crap with no effect.

I've set memory to a minimum of 512 and a maximum of 1024 MB.

Finally, following the example of what was already there in the text box, I
entered the JVM options one per line.  The tomcat documentation says to
enter them separated by either a "#" or a ";", but I suspect that the GUI
tool may be taking them and turning line breaks into "#" characters for me.

Does anyone have any other suggestions to try before giving up on Tomcat in
favor of either Jetty or (God help me) JBoss?

Thanks much,

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message