tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jesse Klaasse <jesse.klaa...@indicia.nl>
Subject Re: Tomcat 100% CPU usage after moving from Java 5 to 6
Date Tue, 02 Feb 2010 08:23:32 GMT


Christopher Schultz-2 wrote:
> 
> Can you give us a timestamp for when the trouble started? Reading GC
> output is pretty tedious.
> 

I believe the trouble started around 15 - 20 minutes before the end of the
gc log, so that would be from ~61h36m.


Christopher Schultz-2 wrote:
> 
> Also, what happens if you remove all your *GC* options (other than
> logging) from your JAVA_OPTS?
> 

I am quite hesitant to try this. This is a production environment, and all
in all Tomcat is performing pretty good now, in comparison to what the
situation was before.
By "all" GC options, do you also mean the UseConcMarkSweepGC? Wouldn't the
GC become serial then (with pauses which stop the whole webapp for a while)?
And also the +DisableExplicitGC?


Christopher Schultz-2 wrote:
> 
> Is this reproducible?
> 

Well, as I said, Tomcat is working much more stable now than it did before.
However, once in a few days it still becomes unresponsive, while CPU usage
stays incredibly low. I have tried load tests using jMeter on our
development environment, but it's working fine then. Must have something to
do with the "real" (more diverse, less predictable/repetitive) traffic on
the production environment, I guess..
-- 
View this message in context: http://old.nabble.com/Tomcat-100--CPU-usage-after-moving-from-Java-5-to-6-tp27305110p27416818.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message