tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luis Esquivel <LEsqui...@copera.org>
Subject RE: 64bit IIS 7 and ISAPI Connector Question
Date Tue, 02 Feb 2010 19:36:28 GMT
Ok,
This for anyone that might have to do this in the future.  We have the Connector working with
Windows Server 2008 R2 (64 bit OS).  BTW, this server comes with IIS7.5.

It works fine with the 32 bit version of the isapi_redirect.dll.   The problem I was having
was that I was making the registry changes to the wrong location for a 64 bit OS.

32 bit OS registry location:
[HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Jakarta Isapi Redirector\1.0]

64 bit OS registry location must be here:
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation\Jakarta Isapi Redirector\1.0]

The difference is this "Wow6432Node".

OR save yourself some time and use the isapi_redirect.properties file instead of changing
the registry.

Thanks.

-----Original Message-----
From: Jordan Michaels [mailto:jordan@viviotech.net] 
Sent: Tuesday, February 02, 2010 11:33 AM
To: Tomcat Users List
Subject: Re: 64bit IIS 7 and ISAPI Connector Question

You're welcome. Let us know how it goes. =)

Warm regards,
Jordan Michaels
Vivio Technologies
http://www.viviotech.net/
Open BlueDragon Steering Committee
Railo Community Distributions


Luis Esquivel wrote:
> Thank you for your answer.  We are trying that.
> 
> -----Original Message-----
> From: Jordan Michaels [mailto:jordan@viviotech.net] 
> Sent: Monday, February 01, 2010 4:47 PM
> To: Tomcat Users List
> Subject: Re: 64bit IIS 7 and ISAPI Connector Question
> 
> Not personally, no (which was disappointing). I'd suggest giving the 
> 32-bit version of the connector a try. I got that one to work on a 
> 64-bit server very quickly and I have yet to see performance issues due 
> to it only being 32-bit.
> 
> Unless you have specific 64-bit connector requirements, the 32-bit 
> version should be just fine.
> 
> Warm regards,
> Jordan Michaels
> Vivio Technologies
> http://www.viviotech.net/
> Open BlueDragon Steering Committee
> Railo Community Distributions
> 
> 
> Luis Esquivel wrote:
>> Hello,
>>
>> Has anyone gotten the above combination to work together? (64bit IIS 7 and ISAPI
connector)
>>
>> I get the following error:
>>
>> HTTP Error 500.0 - Internal Server Error
>> Calling GetFilterVersion on ISAPI Filter "c:\xxxx\isapi_redirect.dll" failed
>> ...
>> Error Code 0x80070002
>>
>> Any help on this would be greatly appreciated.
>>
>> Thank you!
>>
>> Luis Esquivel
>> Application Development
>> Public Employees' Retirement Assoc. of Colorado
>> 1301 Pennsylvania Street
>> Denver, CO 80203
>> 303 - 837 - 6296
>>
>>
>>
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message