tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carl" <c...@etrak-plus.com>
Subject Re: Tomcat dies suddenly
Date Wed, 17 Feb 2010 13:14:18 GMT
Just an update.

A quick refresher.  Server A has been rebuilt with eliminating the JRE 
before Slackware is installed.  The jre from Slackware was allowed to be 
installed and was then removed using the package tool.  The applications on 
both servers have been upgraded to mysql-connector version 5.1.11 from 
3.1.12.  Have been running on server A for four days witout incident (before 
I start celebrating, I remind myself that, at times, the system ran for 10 
days before failing.)  Yesterday, there was a moderate load and people were 
accessing several of the applications... I plan to force that today as that 
seemed to provoke the failure in the past.  However, as Chris pointed out, I 
won't know if it was the change in the Slackware install or the change in 
the mysql-connector.  If we go another week without failure, I plan to 
switch to server B to see if I can make it fail.  Sure would be nice to know 
that we actually cured the problem.

Andre - we don't use OpenSSL.

Chris - I am running inside of strace.  If we do get a failure, I am hping 
to get at least some information.  You noted that it may take several 
cycles, I agree.

Tony - I haven't tried brining up a separate application to see how it 
bevaed under load.  I have used JMeter to stress the server (don't remember 
which one) repeatedly hitting a small corner of the application... the 
server behaved perfectly, even with out of memory conditions.

Mark - I have not yet tried the IBM JVM because I am waiting to see the 
results of the current tests.  I am trying to go slowly enough to know that 
I have actually solved the problem not just befuddled it.  And, with a 10 
day cycle time, testing options can take a long time.

In my area (Charleston, SC) there are people, mainly ministers, that claim 
they can cure health issues by laying their hands on a person and saying a 
few words.  I was thinking maybe Andre could do the same for my servers, you 
know, with his telepathy thingie and all.

Thanks,

Carl

----- Original Message ----- 
From: "Christopher Schultz" <chris@christopherschultz.net>
To: "Tomcat Users List" <users@tomcat.apache.org>
Sent: Tuesday, February 16, 2010 4:55 PM
Subject: Re: Tomcat dies suddenly


> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> André,
>
> On 2/16/2010 4:41 PM, André Warnier wrote:
>> So what now ? I leave this list for 3 days to go earn my keep, and when
>> I come back this silly crash issue is /still/ not resolved ?
>
> Well, we've been waiting for you to bring your expertise to bear on this
> issue, André :)
>
>> still on my trip about the SegFaults caused by some native non-kosher
>> executable module..
>
> I'd be surprised if this was the problem: Carl is installing Sun's JRE,
> which should have everything it needs. He says he's not playing around
> with any native code, so I wouldn't expect anything to be incompatible.
> I'm not saying it's impossible... just that I'd be surprised if it's the
> case.
>
> I'd think you'd get something other than a SIGSEGV anyway... attempting
> to load an incompatible library ought to get you some other error...
> though I'm not sure which. You could probably try to force that to
> happen with something like this (in Java, of course):
>
> System.loadLibrary("my-bad-arch.so");
>
> ...and see what happens. I don't have a library of the wrong
> architecture laying around right now. I tried to load some random file,
> and I got an UnsatisfiedLinkError, but that's at the Java level. I have
> no idea what would happen if the native X11 graphics library was being
> loaded by the JVM and wasn't compatible...
>
>> Appeal to the experts : considering the lenghtily expounded symptoms,
>> would it be possible that one obscure corner of the SSL code or data is
>> being used only occasionally, and that such occasional usage could cause
>> the symptoms here observed ?
>
> It's possible. If SSL is in use, consider "downgrading" to the pure Java
> connectors (i.e. no APR... enjoy re-configuring Tomcat to use the
> different-style SSL configuration) to see if that clears things up.
>
> strace would indicate that this was the problem if you had multiple
> runs: the openssl libraries would always be in the mix of the stack trace.
>
> - -chris
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.10 (MingW32)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
>
> iEYEARECAAYFAkt7FDsACgkQ9CaO5/Lv0PC1cgCfRf9qHNkMJEs54I/CCAxuzBc8
> zroAnRLGS53mv6V/T1sxur1vEekbd3Ym
> =XaqE
> -----END PGP SIGNATURE-----
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message