tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Ryan" <st...@acme.ie>
Subject w3wp randomly crashes when redirector is used
Date Wed, 03 Feb 2010 14:56:09 GMT
Hello

 

I really hope someone can help me with this. I have been trying to figure it
out for days and I am beginning to go mad!

 

The issue I am having appears to be very similar to
https://issues.apache.org/bugzilla/show_bug.cgi?id=45063. It might even be
the same issue.

 

Note I can recreate the problem on various flavours of Windows, and in IIS 6
& IIS 7. 

 

Details of the issue:

 

I have a web application which lives under the "Default Web Site" in IIS 6,
and which has its own app pool. The redirector (isapi_redirect.dll 1.2.28)
lives under the DefaultAppPool. 

 

The user would log into our web application (which uses our app pool) and
everything works as expected. If he then uses functionality which uses the
redirector (and the DefaultAppPool), w3wp.exe will probably crash. (I say
"probably" because sometimes it works without error).

 

Note everything works fine (i.e. there is no crash) if I run the
DefaultAppPool as "Local System"; the problem only seems to exist if I run
the DefaultAppPool as "Local Service" or "Network Service". 

 

Details of the crash:

 

In the Event Viewer I can see the following -

 

Faulting application w3wp.exe, version 6.0.3790.3959, faulting module
ntdll.dll, version 5.2.3790.4455, fault address 0x0004f053.

 

And if I catch the crash using Debug Diagnostic Tool -

 

Thread 5 - System ID 6140

Entry point   w3tp!THREAD_MANAGER::ThreadManagerThread 

Create time   01/02/2010 13:13:26 

Time spent in user mode   0 Days 0:0:0.0 

Time spent in kernel mode   0 Days 0:0:0.15 

 

Function     Arg 1     Arg 2     Arg 3   Source 

ntdll!RtlpWaitOnCriticalSection+c5     00000000     00000000     4b66d376


ntdll!RtlEnterCriticalSection+152     6a6ee4e8     6a6b9ae6     00000000    

isapi_redirect!TerminateFilter+c24b     00000000     00000000     76bbcc54


isapi_redirect+9ae6     01459180     4b66d376     00000000    

isapi_redirect!TerminateFilter+21435     00000000     10000000     01b6dd18


isapi_redirect!HttpExtensionProc+29c     00000000     732448ee     73243b7a


iisutil!STRU::STRU+c     73243b7a     0157e69c     7327a93f    

nativerd!CONFIG_ELEMENT::ReferenceConfigElement+f     000cf7f0     00000000
7327a970    

nativerd!CONFIG_ELEMENT_LIST::GetMergedElement+483     73243e08     0157eaa8
00000000    

0x0157e68c     00000000     00000000     00000000    

 

 

NTDLL!RTLPWAITONCRITICALSECTION+C5In
w3wp__PID__5276__Date__02_01_2010__Time_01_13_27PM__226__Second_Chance_Excep
tion_C0000005.dmp the assembly instruction at
ntdll!RtlpWaitOnCriticalSection+c5 in C:\Windows\System32\ntdll.dll from
Microsoft Corporation has caused an access violation exception (0xC0000005)
when trying to write to memory location 0x00000014 on thread 5

 

Module Information 

Image Name: C:\Windows\System32\ntdll.dll   

Base address: 0x76fc0000   

Checksum: 0x00135d86   

COM DLL: False   

ISAPIExtension: False   

ISAPIFilter: False   

Managed DLL: False   

VB DLL: False   

Loaded Image Name:  ntdll.dll   

Mapped Image Name:     

Module name:  ntdll   

Single Threaded:  False   

Module Size:  1.15 MBytes   

Symbol File Name:
c:\symcache\ntdll.pdb\B958B2F91A5A46B889DAFAB4D140CF252\ntdll.pdb   

Symbol Type:  PDB 

Time Stamp:  Sat Jan 19 07:32:54 2008  

Comments:   

Company Name:  Microsoft Corporation 

File Description:  NT Layer DLL 

File Version:  6.0.6001.18000 (longhorn_rtm.080118-1840) 

Internal Name:  ntdll.dll 

Legal Copyright:  C Microsoft Corporation. All rights reserved. 

Legal Trademarks:   

Original filename:  ntdll.dll 

Private Build:   

Product Name:  MicrosoftR WindowsR Operating System 

Product Version:  6.0.6001.18000 

Special Build:  & 

 

There is nothing obvious in Process Monitor which explains what is causing
the error.

 

Do any of you have any ideas what could be causing this? Any advice would be
greatly appreciated.

 

Cheers

 

Steve


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message