tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shanmugham, Dayanand (IE10)" <Dayanand.Shanmug...@Honeywell.com>
Subject RE: JSP 2.0 examples throw security exception - Need help with configuration
Date Tue, 05 Jan 2010 05:44:47 GMT
Hi,

I installed TC 6.0.20 in new folder, recreated Tomcat Server instance in Eclipse, made it
point to new TC 6.0.20 installation folder and all examples work now.

Thanks & Regards,
Daya

-----Original Message-----
From: Konstantin Kolinko [mailto:knst.kolinko@gmail.com] 
Sent: Monday, January 04, 2010 6:26 PM
To: Tomcat Users List
Subject: Re: JSP 2.0 examples throw security exception - Need help with configuration

2010/1/4 Shanmugham, Dayanand (IE10) <Dayanand.Shanmugham@honeywell.com>:
> Hi All,
>
>
> I need help with resolving following error - staketrace is shown below.
> Following is what I did:
>
> 1.      Downloaded TC 6.0 and extracted into D:\TC60
> 2.      Downloaded "Eclipse Java EE IDE for Web Developers." (or)
> Eclipse 3.5 with J2EE Support and created instance of Tomcat Server to
> point to "D:\TC60"
> 3.      Started Tomcat instance
> 4.      All Servlets and JSP 1.2 examples work fine but when I run the
> JSP 2.0 examples, I get the following security exception messages

You missed some steps/details from your description.
When I do the same, Eclipse creates an empty Tomcat instance, without
any Examples apps deployed. Also, it does not run with SecurityManager
enabled by default.

> 5.      I removed the comments from "tomcat-users.xml" file

> staketrace is shown below.

There is nothing useful in the stacktrace. The important information
is from where the AccessController.checkPermission call was made, and
that is not available.

> The full stack trace of the root cause is available in the Apache
> Tomcat/6.0.20 logs.

By the way, the logs will be in
.metadata/.plugins/org.eclipse.wst.server.core/tmp0/logs in your
workspace.

What are the exact version of Sun JRE that you are using? I see that
Tomcat version is 6.0.20.

Are all the examples failing, or you have a specific sequence of steps
that causes the failure?

You may want to try 6.0.22 release candidate, see the thread here:
http://markmail.org/thread/df55xredhflfqnnn

Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message