tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Eustace" <meust...@attevo.com>
Subject Files in Subdirectories not being served.
Date Mon, 25 Jan 2010 13:05:32 GMT
Hi,

I am running Tomcat 5.5. I have a deployed application and in addition I
have a directory and subdirectory structure that stores and serves
supporting files such as .js and images. For the latter, I have just
created an application by typing in the virtual path and physical path
of the files. My application works fine, however only supporting files
from the root directory of the supporting app are served e.g.

http://localhost:8080/img/foldericon.gif
in
c:\Progra~1\Opentext\support\foldericon.gif

but if a file is in a subdirectory, it's not served e.g.

http://localhost:8080/img/brava/LogoBall_DK.gif
in
c:\Progra~1\Opentext\support\brava\LogoBall_DK.gif

There is no difference in security on the folders, so I presume it is a
config setting for either Tomcat or the app that is causing the problem.
The error log contains:

127.0.0.1 - - [22/Jan/2010:15:50:50 +0000] "GET
/img/brava/LogoBall_DK.gif HTTP/1.1" 404 1030

This is a standard not found error.

My inf file is:

<?xml version=\q1.0\q encoding=\qutf-8\q?\>
<Context
 docBase="C:/Progra~1/Opentext/support"
 path="/img"
 useNaming="false"
 workDir="work/Catalina/localhost/img"\>
</Context\>

I've tried wildcards on the end of the docBase and path, neither of
which made any difference.

Any ideas? I've tried Google and the docs and can't find anything :-(

Cheers,
Matt.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message